Jump to content

v570 Blank Screen...

Recommended Posts

Need Help....

In the begining of the OS Update after the erasing the system files there was a comunication fail and then...nothing....no system....

After I read on the forums to go step by step....I tried to update the bin library....After erasing the bin lyb again comunication fail....

Now I have a blank screen and beeping from the PLC....When I try to make an update...on the middle of the update...comunication fail....


Com1, br 115200,

win7, 64bit


Link to comment
Share on other sites


It seems that indeed the BinLib version cause to this issue.

Please try to recover the PLC as follow:

Use COM1 RS232 115200 baud rate 2sec time out

Connect 6 wire cable instead of the 4 wire cable.

Reboot the PLC

The PLC should beep > tap once to stop the beeping

Go to VisiLogic>communication & O/S, the 4th tab is system modes

Check the communication by clicking on the GET button

If you have a communication>Switch to Factory BOOT

Go to O/S tab>check Download only the BinLib by clicking on the Advance button>BinLib (only)

If the download will success, then replace to 4 wire back and download the BOOT and then the O/S.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

I don't know how to thank you Mozes......

It worked but not with a 6 wire cable....As you said direct RS232, till now I was using USB to RS232 and losing the communication all the time....I went to a friend and with an older PC and built in RS232 port....

Saved it....

Now it's working as a charm....


Link to comment
Share on other sites

  • MVP 2023

The topic of the quirky USB->serial converter has been brought up before, but it's worth mentioning again. I did a project this year integrating our standard converter (MJ10-22-CS35 using the Prolific PL2302 chipset) into a test and data acquisition system running tests on appliances. This converter usually works fine but is not isolated and if there is a ground potential difference between the PLC and the computer the converter is plugged into then all kinds of intermittent gremlins get into the system, resulting in communications failure.

I swapped out the converters to isolated ones recommended by Walkerok - part number USB-COMi-M available at several online sources. These are more expensive than ours but work extremely well. I've had no problems since I swapped them out.

Joe T.

  • Upvote 1
Link to comment
Share on other sites

  • 5 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...