Jump to content

Recommended Posts

  • MVP 2023

Hi everyone,

 

has anyone else had trouble doing an OS update in 9.7.55?  ie Help/Check for Updates/Operating System

 

The program told me I needed to do an update for a controller.  As soon as I do this requested action I get a Run-time error "13" Type mismatch warning, and on ok VisiLogic shuts down.

 

I installed everything without UAC and am running the exe as admin in Win 7 32, including the shortcuts.  I did a full uninstall/reinstall in case I messed anything up, but have the same result.

 

Please give it a go and advise.

 

cheers,

 

Aus

 

post-12856-0-50623800-1430006586_thumb.jpgpost-12856-0-04059100-1430006587_thumb.jpg

Link to comment
Share on other sites

Hello,

 

Our R&D fixed a DLL file and it seems that it solved the problem on my desk.

Please follow the next steps:

  • Download the fixed DLL attached to this post
  • Extract the ZIP file, there is a DLL file inside a folder
  • Close VisiLogic V9.7.55
  • Copy and replace the DLL file in C:\Program Files (x86)\Unitronics\Unitronics VisiLogic_C\VisiLogic Self Reg DLLs
  • Lunch VisiLogic
  • Verify the correct PLC model in  HW Configuration
  • Open the project and Perform Build – All from Build menu

 

I hope it helps..

UnLvUpd1.zip

Link to comment
Share on other sites

  • MVP 2023

Thanks R.

 

That seemed to do the trick.

 

Also, a suggestion for the upgrade wizard.  The need to only do it via the com port should be strongly highlighted in the very first window before you get anywhere near the actual process.  I have a site visit to do because I didn't note this important warning early enough, tried to do it via the net.  Clicked on proceed just as I fully absorbed the info...damn!  My fault, but a slight window alteration would help.  It didn't help that the entire procedure was initiated by me accessing the controller remotely to do a full download and being told that I had to do the required update.  The natural thinking is that it can all be done by the link that has told you the update was needed, but this isn't the case.

 

FYI, I also had trouble using version swapper on this build as it wouldn't load everything correctly during "Register".  This seems to be cured, too, but might be totally unrelated as I have had the program in and out a few times since first trying.  I might have been originally trying to use the swapper in 9.7.0, not the latest.

 

cheers and thanks,

 

Aus

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...