Jump to content

Problem with io-atc8 and thermocouples

Recommended Posts


I have a problem  with thermocouple sensors, I get value of 32767 for seven of my inputs and 11460 for one of my input. Do you have any Ideas of what can i do about it? How can I have proper temp values for my PLC?

I'm intending to get temperature trends and numeric variables for my HMI.


What I have allready done:

- disconnected all my sensors and have a short wires connected in every channel

- changed the io-atc8 module's internal jumpers to B selection

- changed hw-configuration for all input channels to K-type and variables from MI100-107 



Visilogic 1040



EX-A1   -   expansion adapter

IO-ATC8   -   8-channel analog input module



Thermocouple K-type

Link to comment
Share on other sites


There is no problem to use TC K type (or any other type) withg IO-ATC8.

You have to set DIP switches inside into right position.

You have to add IO-ATC8 to PLC Hardware Configuration and configure Inputs as TC K. Then connect TC with a right polarity to IO-ATC8 terminals.

Resulting temperature in 0.1 C will be in linked MIs.

*27.9 C will be equivalent to 279 in linked MI.

Next is a link to related document.


I hope this helps.

Link to comment
Share on other sites

"You have to set DIP switches inside into right position."

       If you mean by dip-switches a jumpers that are mentioned in manual, so yes I have checked these jumpers they are all at B.


"You have to add IO-ATC8 to PLC Hardware Configuration and configure Inputs as TC K. Then connect TC with a right polarity to IO-ATC8 terminals."

       The configuration should be as you mentioned. Now I have short wires connected to sensor terminals, but i have had also thermocouple connected and i tried to change polarity but it didn't have any effect. With short wires, shouldn't it show a module inner temperature.


Any other ideas? 

Link to comment
Share on other sites

I am reading what you have said and one piece does not make sense to me.  You say you have short wires connected.  What does that mean?  If you are saying that you have a single wire shorting (for example) T0+ to T0- then this will never work.  You can make a home made thermocouple out of any thermocouple wire set by stripping and twising the positive and negative ends together on one end and then correctly connecting the other end to the "T" terminals.  (The wires can not touch anywhere exect the end you twist together or it will not work correctly)  The wire with the red insulation on it goes to "T-" and the other color (color depends on thermocouple wire type, K type is yellow) goes to "T+".


The wire in your case must be K type thermocouple wire and any other wire types will not work.


Good Luck



PS:  In your first post you said that all inputs are maxed out and one is different.  Are these numbers the same all of the time........Paying attention to the one that reads 11460 even if nothing is connected to the input in question on the IO-ATC8.  If the numbers do not change then you are not communicating between your PLC and the EX-A2X module.  When communications is lost the numbers in the MI get fixed in place wherever they were last.  Test this by forcing a value into one of the MIs you used to map the thermocouple inputs .................. If you can change the value of the MI you are not communicating .............. If you can not change the value from what is there already then you are communicating.

  • Upvote 1
Link to comment
Share on other sites

Thank you for your answers, I don't have any K-type cable's only one K-type sensor. My main goal is test everything in my workshop and then go to assembly it in the final destination, where i will connect the thermocouples. 

I am assuming that with these short wires I should get ambient temperature, not the channels maximum reading that I now do have.

The one channel that I told is giving value 11460 is floating, so the value changes a little bit.



Here is one post from moderator Joe T, according to this the shorted channel should give ambient temperature, the post is from this thread:  http://forum.unitronics.com/index.php?/topic/1908-io-atc8-problem/?hl=thermocouple


The IO-ATC8 card is not isolated, and noise from the system can cause very odd behavior. The first thing to do is disconnect all the thermocouples from the card and replace each one with a short jumper (I use a cut off paperclip) across the thermocouple terminals. You should read ambient temperature on every channel. If you don't, there is something wrong with the hardware or the configuration. If you do read ambient, re-connect the thermocouples one at a time until the problem shows itself.


Link to comment
Share on other sites

Okay, I started to suspect everything, 

-So I placed io-snapin module in the back of my V1040 PLC and tested one analog voltage input with 1,5 voltage battery and it worked like it should.

-Then I changed my io-atc modules first two analog inputs to voltage mode with two jumpers and connected the 1,5V battery in its terminals and no success.

-After this I tried to change EX-A1 module to a another one and nothing changed

-Then I changed PLC to a Vision 120, and still couldn't get anything else than maximum, from the channels.


So do you have any suggestions how can I troubleshoot the io-atc module

Link to comment
Share on other sites

  • MVP 2023

The jumper trick works for testing.  You mentioned in your last post that you have an EX-A1 module, instead of an EX-A2X module.  Have you tried the newer module?  You may be running into an O/S issue.


Do the communication lights come on on both the expansion modules?  Do the out of range lights come on?


Joe T.

Link to comment
Share on other sites

  • 3 weeks later...

I have looked at your file.  You are scaling values into the exact same MI locations that you have designated for the thermocouples on the ATC8 module in your hardware setup.  Don't do this.  The thermocouples do not need any scalling and the values directly off of MIs 200-207.  Delete the scaling blocks and look at it again.


The information in the MIs 200-207 should be read with one decimal point implied  so for example a number of 506 in MI 200 reads 50.6 degrees C based on how you have your hardware programmed in Visilogic.




Link to comment
Share on other sites

Sorry my mistake, I did like you advised for a start, but then I started to suspect everything and that's why I added these linear functions. The Idea was that the MI:s are then used once in a program, I could also try overight the MI's but I couldn't.

When I sent the program to you I changed the MI-numbers back to original, but forgot to delete the linear function's. So this wasn't the solution for me, I hope there is some misstake as simple as that in my project, but I cannot figure it out.

I cannot understand, because It should be simple to get value from my expansion modules to a my HMI. Maybe this is still some kind of version problem. The PLC/HMI is unused and not so old, but my expansion modules might be very old, IO-ATC8 is V3.00, but at EX-A1 and V1040 doesn't have any version numbers.


But then again V1040 it seems to communicate with V1040. Only the reading is allways maximum.

Link to comment
Share on other sites

  • 1 year later...

I ran into a situation -

I have my Type K thermocouple input feeding directly into the PV value in my PID Config function block. The system was running fine and the output was firing at 80% for a particular set point. One of the thermocouples in my system failed in the middle of a cycle and the thermocouple read 32767 (out of range). At that point, the PID output locked to 100% and started heating up the system rapidly. This seems counter-intuitive of what actually should have happened as if the thermocouple value is much higher than the set point, you would think that the output % should go to zero. 

I did not make a note of the PID status at that time, but I believe from the definitions it should have been +8 (Integral Wind Down). 

Shouldn't the PID block catch the out-of-range thermocouple value and disable the output?  

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 years later...

customer had issues with the loss of 3 of the 4 tc channels.

we tried downloading new updated program from version 5.2.3 to version 9.5. only one tc channel shows close to correct the other show out of range

so i suspect the first tc input is also not correct, but i do not get out of range alarm.

is there something in the software version that is causing this issue

machine has been running since 2008

Link to comment
Share on other sites

  • MVP 2023

I haven't had any software issues with the ATC8.  It works very well.

If it's a system that's been running and the jumpers inside the module are properly set then try disconnecting the thermocouples and putting a jumper across each TC input - this should read ambient temperature.

If this doesn't work try replacing the module.  Your customer may have had a spike hit the module that damaged it.

Joe T.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...