Jump to content

Recommended Posts

Hi, I'm a new user and I've been trying to get a PTO pulse signal from one of the high speed outputs of my V130-33-TR34 to send to a stepper motor driver. I just got the PLC so it's set to default jumper settings.


I pretty much followed the webinar on the Unitronics site and I'm pretty sure I did the wiring right (pin 1 on the transistor outputs to driver, pin 5 to PLC ground). Hooked it up to an oscilloscope and I don't get anything out. When I run the PTO move command, it turns the MB on for "PTO Move Success."


Tried going into the HW Configuration and trying to get a PWM signal out by setting up one of those and initializing Frequency to 500, Duty cycle to 500 (50%), and then downloading a program with just ---|SB2|---(MB0)(S) where MB0 is the PWM "Run Bit" and still nothing. Anybody see something simple I overlooked or something I did wrong? If not, any ideas what might be going wrong? Thanks in advance

Link to comment
Share on other sites

  • 4 years later...

Hello, I'm quite old for the Unitronics ladder, but mainly in Jazz.

I am having the same issue with my V130-33-TR34, all the programming side should be okay, only a sample application trying to get it to work - go to target with given velocity in PTO.

It is configured, I set the profile and the succes bits are on both, but then when issuing the Move it only sets the succes bit on, but the stepper motor doesn't budge.


My wiring is such: O1 and O3 to PUL + and DIR + of the stepper driver (through 2k resistor since it has 24V), then the PUL - and DIR - to 0V on the PLC. I have tried to switch the PUL and DIR from + to - and the 0V too, but no luck.

When reading position from Read PTO block, it starts moving, but also my target is 2500, units and pulse/unit are 1=1, but the read position stops at around 4290 - 4320 values.

Can somebody explain how am I supposed to wire/program/change something on my setup so I can get it going?

Link to comment
Share on other sites

Hi Joe,

I have taken your example and also did rewire the +24V on PUL+ and DIR+, I had it on 0V before, but switching that I have managed to getthings moving.

Now as I'm writing my ladder it seems that 0 channel is switching the direction nicely when inputing + or - target positions, but the 1 channel is only hoing one way. What could be the reason?


I will post the program later when at my workplace.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...