Jump to content

DataXport runtime error 429 with Excel 2010


Recommended Posts

I use DataXport for a long time without problems on my old PC with Windows XP SP3 and Excel 2000.

Now I bought a brand-new PC from Acer with Windows XP SP3 and Office 2010 (Excel 2010).

After the new installation of DataXport V3.0.1 I receive the runtime error 429 "activeX component can't create object". For the first time after receiving data from the PLC. After the first time at once by calling the PLC.

I tried to solve the problems with suggestions from the old forum. e.g. re-installation of DataXport didn't work. I checked the MDAC-version (V2.8) from Microsoft, but no problems are detected.

Do you have any experiences with Excel 2010 and DataXport?

Do you have any ideas to solve this problem?

Link to comment
Share on other sites

  • 4 weeks later...


We just checked DataXport with Excel 2010 and it's working fine without the mentioned error.

Did the error message appears immediately after openning DataXport? Or, after some action? (Call,Export...)

This error may occur because the ActiveX or COM DLL being accessed is not registered on the system.

Please try as follow:

  1. Install the latest Microsoft .NET Framework
  2. Reboot and delete and files in the TEMP folder on your PC.
    These are usually located in C:\Windows\Temp and in the %temp% environment variable.
  3. Reinstall the component package that includes the DLL being accessed. This will register the DLL.
Link to comment
Share on other sites

  • 1 month later...


the error message appears immediately every time by starting a force call or starting a scheduled call.

Now, I have installed the latest .NET Framework (version 4) from Microsoft, deleted the files in the TEMP-folders and reinstalled the DataXport software.

But with the same result. I always get the runtime error 429 "activeX component can't create object".

Do you suggest to reinstall other Unitronics products? I use on the same PC the VisiLogic software and your UnCmDrv1.dll file with a Visual Basic 6 application. But neither VisiLogic, nor the Visual Basic application have any problems. Everything works fine, except DataXport.

Do you have any further suggestions?

Or can you tell me, which DLL files should be replaced or reinstalled or changed in any way?

Link to comment
Share on other sites

  • 1 year later...


Runtime error 429: “ActiveX component can’t create object”

Here is a solution to this error:

Reinstall Windows Script

Repair Windows Script File Information in Registry

Reregister Concerning File

Reset Internet Explorer Settings

Restore your Computer

Repair System Files

i also faced this error many times but i fixed it, i also got some help from this article error429 , hope someone might get help from this article.

  • Upvote 1
Link to comment
Share on other sites

  • 6 years later...

Reregister the File
There have been instances when a 429 error is accompanied by a particular file name. In this situation it could be the case that the specified file is not properly registered in your Windows registry. Thus, reregistering this file may be all that is required to fix this problem. Anyway, you can do this method check out on this URL

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...