Jump to content


Recommended Posts

Hey guys,

I have a UniStream 7" PLC connected with EX-RC1 expansion module via CANBUS.
The CANBUS is connected according to the info in the datasheet with 120 ohm resistors and everything.

The complete configuration that the PLC communicates with from left to right is as follows: EX-RC1, 3 x IO_D16A3_RO16, 2 x IO_ATC8/AI8, IO_D16_A3_RO16.
The PLC and the EX-RC1 is grounded and connected as it should. EX-RC1 is programmed (initialized UniCAN) and the LEDS are all working propperly (PWR ON, I/O COMM ON,  BUS COMM ON). Accordingly I am able to read/write all the inputs/outputs. So, the whole system and configuration is working propperly.

A few (2-3) months later EX-RC1 dies (only PWR LED is ON). I can't read/write any of the inputs/outputs and the IO modules I mentioned earlier all blink ( no communication established).
I tried restarting the whole configuration by turning the power supply OFF and then ON. Tried to reprogram the EX-RC1 but when the download starts it shows an error that the device is not available (not sure what the error said). So I thought to myself what the heck. It died, it happens and I replaced the module with a brand new one and installed a separate power supply used only for the EX-RC1.
The whole configuration started working again, the comm was up and the PLC software was fully functional (able to read/write and execute).

However a few months later ... surprise ... EX-RC1 dies again. The exact same circumstances.

Is this a compatibility issue or?

Thanks in advance for your help.

Any suggestions/ideas are really appreciated.


Link to comment
Share on other sites

  • MVP 2014

I can only offer these as general suggestions, but it sounds like an isolation/grounding issue.

Does the failure correspond with any particular event, such as a thunderstorm, or machine cleaning cycle?

There's a lot of experience and engineering behind a good wiring design that avoids isolation and grounding problems.  So that is best solved with local hands-on expertise

Some points to note:

* If solenoids are being used ensure they have a flywheel diode fitted.  Use Solid-state relays for isolation, not mechanical relays.

* If variable speed drives are used, ensure the motor cabling is physically separated from all control, signal and comms cables.  Use shielded cables and RFI/EMI filters as specified by the drive manufacturer and relevant wiring standards.

* Ensure the CAN bus comms is powered separately to the IO devices.  It is best to use a 4-wire CAN cable and supply CAN bus power from the PLC end.  Don't power the  CAN interface of the EX-RC1 from the same local power supply as the IO devices.

* if the remote EX-RC1 system is on a generator/battery/solar system, consider installing a DC-DC convertor or a small UPS, that gives clean power to the EX-RC1. 


I hope this helps.


  • Upvote 1
Link to comment
Share on other sites

Thank you for your help Simon.
Your advice gave me a direction to pursue.

I wrote by mistake in my first post that there is a separate power supply for the EX-RC1. I meant the CAN bus comms.

The CAN bus comms is powered by a separate power supply and there is a separate power supply for the PLC, EX-RC1 and the IO modules.

Is it possible that this is causing the problem?
Should the CAN bus comms and only the PLC share the same power supply and a separate one for the EX-RC1 and the IO modules or something else entirely?

Link to comment
Share on other sites

  • MVP 2014

I would stick with the separate power supplies as you have them.  

The CAN comms power supply is isolated internally, so using a separate power supply maintains this isolation.  Just to check, is the 0V of the CAN power supply connected to ground or 0V of the PLC supply? I believe it should be floating, that is not connected to the main system 0V or GND.

I think this then puts the focus on what is happening at the EX-RC1.  Check the datasheets, as I know that for some modules Unitronics ask that the 0V rails of the different power supplies are connected together. 

Hope this helps.

Link to comment
Share on other sites

  • MVP 2023

Additional to Simon's great advice, I'm assuming that the CANbus line is good quality, shielded and with the shield correctly junctioned & earthed.

I would also be considering arranging a return of both EXs to Unitronics HO for them to ascertain exactly what has failed.  This may turn up something that will narrow things down.  They should surely be interested in case there is a batch fault etc., although it is unlikely.



Link to comment
Share on other sites

  • 3 years later...

To restart and idle EX-RC1 do the following ( with only a 24v DC PSU connected to it ):

- With the power off switch all the DIP switches On ( Boot Strap Mode )

- Power it, it will power up with steady PWR LED and flashing I/O COMM and Bus COMM

- You can now connect via Prg port 57600 BAUD, Get OPLC information returns Model EX-RC1-BOOT, Hardware A, OS Version 2.00 (20) or similar

- Power it off, change DIP switch all OFF ( Stop Mode )

- Power it, it will power up with steady PWR and flashing I/O COMM

- Get OPLC Information returns Model EX-RC1, Hardware A and OS Version 5.04 (14) or similar

- Get PLC Status will show Run/Stop = Stop

- Press the Run button, Get PLC Status will show Run/Stop = Run

- Power it off, change DIP switches to required address 1 to 60

- Power it, it will power up with steady PWR and flashing Bus COMM

Normal function is restored.

Best regards


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...