Jump to content

M91-2-T1 Communication Issue


Recommended Posts

Hi y'all:

I've been using M-91 PLCs successfully in various applications and only recently came across a customer supplied M91-2-T1 that does not seem to be able to establish communication to program via the RS232 port.  The PLC powers up fine as I see the old legacy program running on the hardware; however, whenever I try to download some test ladder logic, or even pull some PLC data, I get the "Communication could not be established" error message.

Things that I've tested:

1) The COM port has been verified

2) I've verified the function of the programming cable chain:  Serial adapter and Unitronics MJ10-22-CS25 cable verified by using the same setup to program two different M-91 PLCs that I had lying around (for completeness, these were the M91-2-R6C models - so not an exact match).

3) I've tried adjusting internal jumpers for all combinations of RS232 and RS485

4) I've tried using the "i" button on the PLC to match the RS232 parameters to that of the PC.

In case it matters, the M-91 PLC in question has the following specs as indicated using the "i" button:

Model: M91-2-T1

HW Rev: A

O/S Version: 3.80

O/S Build: 05

Anybody have any troubleshooting thoughts or run into something similar?

Link to comment
Share on other sites

  • MVP 2023

Hi Gabe and welcome,

You seem to have done everything.  At this stage I'd be making a cup of tea and then checking a few extra things.

Ensure your jumpers are back to 232.  1 & 2 = A, 3 & 4 = B.  (Although in theory 3 & 4 work ok at A).

1). What is getting listed in the connections description at the bottom of the pc screen during attempts?  Or find ComLog.txt in the main program.

2).  Maybe increase the timeouts on the 232, just to see what happens.  Ensure that what you are using in U90 is the same in the main Windows comm settings area for that port.

3).  Use Hyperterminal as described in the Help files to check the basics of the connection.  Index=communications--> Using Hyperterminal to check PC-PLC direct communications.  See how that goes and report.  Or is that what you did in your point 1?

4).  If that doesn't get anywhere, I'd be carefully probing the port terminals and ensuring that the relevant pin is getting to the board.  Have a look in the port to physically confirm all pins are present and look to be in good shape.



Link to comment
Share on other sites

Thanks for the reply.  Much tea has been brewed and processed.  Troubleshooting results from your suggestions below:

1) The following is from the ComLog.txt in the main program when trying to do any type of communication through the RS232 port (unfortunately, I don't think it's anything too interesting - but I could be missing something obvious):

15-12-16 21:20:44.65    : < 4,9600,E,7,1> 4, 9600, 7, Even, 1, 10, 12000 > Retransmitting
15-12-16 21:20:56.66 < 4,9600,E,7,1>  > Switching Com Port
15-12-16 21:20:56.89 < 4,9600,E,7,1>  > Synchronizing Com Ports

2) Playing with the timeouts didn't seem to do anything.  Different combinations of baud rates, stop bits, parity, etc had no effect.  Manually setting the RS232 parameters on the OPLC to match the PC's didn't work either.

3) When using hyperterminal, no response is received from the OPLC to any PC commands.  I did check the serial cable output by putting a jumper between TX and RX pins to get an echo back in hyperterminal and that seems to work fine.  No response from the OPLC though.

4) I'll take a look at probing the pins tomorrow.  On visual inspection of the port and the board, the pins themselves and board look fine from what I see (comparing it to another M91 that does establish communication fine).   But if there is any damage that I'm not seeing, I probably don't have the capability to do anything about it as my surface mount soldering capabilities are non existent.


Do Unitronics distributors typically repair M91's?  or would it not be worth their time typically to go through the trouble?


Link to comment
Share on other sites

  • MVP 2023

Hmm, starting to lose thoughts.  It definitely looks like it isn't getting anything in on the 232 lines.  I asked about the pins appearance because I have had instances where clumsy insertions of plugs have bent the pins enough out of shape that they don't contact correctly.  It has occured where people have used custom 4 pin plugs in the 6 pin socket.  Use a leaded plug to check continuity b/n that plug's lead tails and where you can probe onto the socket pins with the plc opened.

Clutching at straws now.....

Check the unit ID no. via info mode and ensure it is no. 1.  If it isn't, change it to 1, it shouldn't make a difference but worth a try.

Force reset of the 232 parameters in info mode and try again ensuring all params match.

Perhaps try some older versions of the U90 program?  Start with 3.9.2 which is still there on the website.

I always hate this sort of thing.  It looks like a hardware failure, but then much later I find something simple that is the cause. Anyone else on the forum with ideas?  Joe T is the font of wisdom!  Are you there, Joe?  !!  Maybe there is a comms lock SB on the M90 that I don't know about? I don't believe they have them, but maybe it is there but not generally known?

Repair.....don't know, but don't think they would.



Link to comment
Share on other sites

Here's another round-up of results:

1) Unit ID was always on 1.  Changed it to a few other IDs just to check.  No progress

2) Forced reset of 232 parameters on the PLC info mode.  No progress.

3) Old U90 programs don't seem to work either.  I can't even pull the basic version information nor 232 parameters off the PLC to the U90 software.

4) I've tried resetting the PLC when info mode, and putting the PLC in stop mode.

I think at this time, it's probably best to call it quits and put this PLC out to pasture.  Many thanks for all the support though.  First time on the forum and even though I didn't get the solution I was looking for, I was pleasantly surprised with the support.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...