Jump to content

Recommended Posts

Hi Folks, 

I'm trying to control a Teknic's SDSK stepper-type motor with a Vision V430 using its PTO functionality but with no success. I don't know if it's a software or hardware problem. Should it be possible for me to see any of the high speed outputs changing state when viewed in Online Test (F9) mode? Because at the moment everything seems to be dead.

The bit of code I'm using is based on a Unitronics example which I've tried to adapt for a V430 and I'm using VisiLogic 9.8.65

If anyone could give suggestions as to what I'm missing here it would be much appreciated.

Best Regards


PTO Test ' Yair.vlp

Link to comment
Share on other sites

Is register for position changing, MI12 in your example? If it is then outputs should be firing.

Also, steppers can lose position if load is higher. If you have an encoder you could write your own code for positioning and move motor with high speed output instead of PTO functions ("High Speed Outputs (Step Control)" in "Hardware Configuration"). You could try this method for testing, if motor still doesn't move it might be wiring error.

Link to comment
Share on other sites

Thank you Isakovic,

Yes MI12 changes as expected along with the HMI display in general although I still cannot see any of the outputs changing state when in F9 'online' mode.  The motor direction settings seem to also work ok  on the display and within the PTO function blocks but again I don't see the corresponding output (O2 I think) change.



Link to comment
Share on other sites

  • MVP 2023

Is the motor actually hooked up?  Or are you just looking at the plc in online mode like you have said earlier?  If just the latter, online mode naturally has time constraints as to what it can display, and quickly pulsing sources are often not shown as such.  Don't simply go on what is "displayed", do actual readings on terminals.

cheers, Aus

Link to comment
Share on other sites

Thanks for that Aus,

Yes the motor is connected and it is lightly loaded.

I realize that with scan time issues online viewing of the Step pulses would be problematic but was thinking that the Direction output would be of a much lower frequency and seen easily.

...think I might have to see if I can remember how to use my scopemeter !



Link to comment
Share on other sites

Well, the wiring checked out ok. A clocking circuit 'conventionally' assigned
to O0, O2 and (for the hell of it) O6 resulted in their corresponding terminals
pulsing between 0V & 24V as expected and as indicated in F9 Online mode.

These outputs could not be seen to be switching like this when the PTO ladder modules
were used so is there some output assignments I'm missing or jumpers or hardware 
configuration still to consider?

Link to comment
Share on other sites

.... not too familiar with Unitronics stuff but the code in question is in the Main Routine of the Main Module so I assume it is being called continuously.

I'm also pretty sure I did a few Initialise and Resets because early on, after a main power off - power on cycle, I had displayed Config Success = FALSE and

Profile Success = FALSE.    I think these changed after an Initialize & Reset.   But I will double check again tomorrow.



Link to comment
Share on other sites

Initializing &  Resetting the PLC gives the same results. I reduced the Velocity
down to 125 which gave a longer time before 'at position' was reached but O0-O3 remained
at a steady zero on the laptop display.

Could someone please confirm whether or not I should be able to see the outputs
changing during F9 Online mode? - just in case these PTO modules somehow control the 
outputs in a  different manner to the ladder code I'm used to.

Link to comment
Share on other sites

  • MVP 2023

No, you're not going to see them online.  The PTO function bypasses the "O" memory type so it never gets reported to the software.

Time a sanity check.  Let's try to move the motor using the built-in functionality of the High Speed outputs configured for Step Control in the Hardware Configuration window.   

According to the program in your first post, you have a V430-TR34.  We'll set up O0 to fire pulses out to move your motor.  One direction only for now.

Load the attached program and see what happens.  You drive it from the screen - no logic required.  Your step output should be connected to O0.  Also, post a link to your exact motor manual so we can look at the wiring.  Does the step input on the controller have an internal pull-up resistor for the NPN output on the PLC?

Joe T.  

HSO Step Test JT.vlp

Link to comment
Share on other sites

With Joe's code and an LED & Resistor across the 'Step' pins I could see that the voltage level
was pulsing correctly.

There was also a steady 24V across the Enable terminals.

I tried to control the 'Direction' output (O2) with the original code example but couldn't get this to
work although it did work when conventionally addressed via ladder logic. I don't know why this is.

So it must be the motor that's faulty or incorrectly configured - I'll swap it with a 2nd one to see.

Thanks everyone.


Forgot to mention:  Teknic's wire colour codes should be ignored.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...