Jump to content

Communication problems with USC-B5-B1


LeonMötter

Recommended Posts

I have been having a lot of problems trying to communicate with a new out of the box USC-B5-B1. 

My first attempt at downloading the program was over USB. When i plug in the USB cable the device is recognizable in the download menu, but when i select it and press the download button the download menu disappears and nothing seems to happen. I have tried rebooting the PC and the PLC and unplugging the USB cable en and plugging it back in with no result. 

My next train of thought was maybe it has something to do with the PC that i am using, so i swapped PC's and did a brand new installation of Unilogic. The result was exactly the same. The PLC is recognized but i cant seem to do anything  with it.

My last attempt was to use the Ethernet port. So i plugged that in and switched my PC to a static IP of 192.168.1.10 and put in 192.168.1.4 (which should be the default for this unit). Unilogic could not find the PLC, But when i use ping in the windows command line with address 192.168.1.4 i do get a response. So there seems to be a connection.  I also tried switching of the firewall in the PC, but that also does not seem to work. 

At this point i am running out of ideas, hence this post and hoping someone recognizes this problem.

To make sure that all the information is here:

PLC: USC-B5-B1 with hardware add-ons: UAC-CB-01RS4_0, UID-0016T_1 and UID-1600_2

Unilogic: version 1.26.90

Link to comment
Share on other sites

Hi;

The issue may be the OS in the PLC is newer than the Version of UniLogic you are using. ( example - OS in PLC is  from 1.31.116, and you are using  1.26.90)

   Program version, UniStream Version, and PLC OS Version must ALL be in synch.

   ( Not like VisiLogic where a Newer OS in the PLC can accept an older program from an earlier version)

Check the OS in the PLC against the Version that UniStream has in it to install to the PLC.

2 Choices:  --  Load  the OS from 1.26.90 onto a USB and install it into the PLC ( May have to force the install)

                         --   Upgrade UniStream to latest version and install the latest OS into the PLC and Upgrade your program.

DanT 

Link to comment
Share on other sites

Thanks DanT,

This morning with a clear i mind i installed the latest version of unilogic to try if that helped and indeed then the usb connection worked. It would have been nice if i just got a error messages with a version mismatch, but that is probably to easy.

The reason i am still working on a older version of Unilogic is that upgrading the PLC firmware on the USC models a pain in the ass. Well not so much the updating part but getting the PLC to read the USB stick. A problem i ran in to today again.  Eventually i got it to work, but then i was a few hours in.

Problems like this really makes me wonder what the problem was with upgrading through a cable. 

Leon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...