Jump to content

Recommended Posts

Im sure this is an easy one, but my first time using unitronics so here goes.


I have a v1040 and i purchased the add on ethernet card.


Card is installed and appears to be happy looking at the status bits.


My program works fine, i only wanted the ethernet card to be able to remote download updates to my data table.


I am unable to ping the PLC.


Both my PLC and the card are set for same subnet.


PLC - - -


PC - - -


I think im screwed up in the cards socket init settings, but i havent been able to locate a decent how to on how to set up.


Im attaching a couple pics here.






Thanks for any assistance.



Link to comment
Share on other sites

  • MVP 2023

As Joe said, no need to initialize Socket 2 - it's already set to communicate with your PC. Make sure of the following:

1) NAME the PLC with the Set PLC Name function block tied to a Power-Up contact (SB1) Should be SB 2.


2) Address both PLC and PC to the same subnet and make sure there aren't any duplicate addresses. (Looks like you've done that)


3) Use a CROSSOVER cable or an ethernet switch between the PC and PLC.


4) Go to Connection / Communication & OS (or CTRL-F9),

      - Select Connection Type TCP/IP (Call)

      - Click on Project Settings and enter the correct IP Address for the PLC, Protocol TCP, Port Number 20256, and the correct PLC Name. Click OK.


5) Confirm settings work by clicking the "Get PLC Information" button.

Link to comment
Share on other sites

  • MVP 2014

Further comment, to ping the PLC from the PC, you don't need to set up an ICMP socket on the PLC.  It should respond to ping requests in its default state.  As far as I am aware the ICMP socket setup is only needed if you want to ping another device from the PLC. 


If you aren't getting a ping response then there is something wrong at points 2 or 3 of Flex727's post above.


If you have added TCP Socket Init blocks I would remove them (but leave the Card Init in place), because, as several have posted above, the default socket configuraiton will respond to PC communication requests.  Removing any blocks you have added will ensure you have the default configuration.  Re-download and cycle power to the PLC.


Also make sure your initialisations are triggered with one-shots, not "always on" conditions.


Also try disabling your PC firewall (if you have one).

  • Upvote 1
Link to comment
Share on other sites

  • MVP 2014

Sorry, just looked at your screenshots, realised that some of my comments are moot, in particular,

  • you have used a transitional contact for the inits
  • even thought you have added a socket init, it matches the default settings, so it should work fine (though I would still suggest deleting it and relying on the default setup, for simplicity).
  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...