Jump to content

V9.0.1 OS Update failure

Recommended Posts


I have a brand new V570 with nice little movie program in it, I went download my app using Version 9.0.1 and it said I had to update OS before proceeding.

Went to Update OS (which I have done before on other Unitronics PLC's), yes I was plugged into port 1, 57600 speed, the OS did the first step then it stopped on the second showing a red X next to it. So I tried to do it again, but it would not start, I had to power down and power back up, but now there is nothing showing on the display and the PLC is beeping once every 2 seconds.

Please advise!


Link to comment
Share on other sites

Well I had to update a program on another V570 just now, I was a little bit leary about doing this since what had just happen yesterday, but I do have one v570 currently running version 9.0.1 and all of it's current firmware, so I thought maybe it was just a fluke with the one incident I had yesterday.

So I changed the program, recompiled and was ready to download, of course it said I needed to do OS update. As I watching the update going from step 1 to step 2, I was worried I would get the error again and have another bad V570, but it actually got through with step 2, and moved on to step 3, as it was doing step 3 the dreaded red X came up and said there was (01x) checksum error on the OS updating dialog, and the display is still stuck on the light Red background, even if I remove power and then power back up its still on the same display with the light red background showing "Factory Boot Boot Error"

Unless someone can tell me what I maybe doing wrong, I have to go back to version 8.6.3


Link to comment
Share on other sites

We're having the same problem at our company (OEM). About 30-50% of our new V570s are bricking when updated to the new version. They usually turn red on the screen just before they brick. Taking these same screens back to v8.6.3 seems to work just fine to bring them back, but they can't be updated to the new software. One thing I've noticed is that the default comm speed seems to be 115200 after they're bricked. I don't know if perhaps the comm speed is changed mid-update on the PLC, thus losing comms in the middle of the update. Just a speculation on my part.

I would appreciate an answer on this ASAP, as we have equipment to ship.

Link to comment
Share on other sites

Please ensure you are using the latest firmware files from our server.

From the help menu: Check For Updates --> Operating System

At the time of this post, the most current versions are as follows:

OS: 3.3(03)

Boot: 2.2(05)

Bin: 1.10(00)

Please try installing manually each portion of the firmware.

You should be using physical port 1 of the PLC and also the max baud rate of 115,200.

From the PLC System Upgrade Wizard you can select "advanced".

You will need to install first just the Bin, then just the Boot, then just the OS.

When it asks if you would like to send plc run command, select no each time.


Press finish after each individual firmware process completes


Select No each time except for last after OS


Link to comment
Share on other sites

Ok, I now have three V570's that are dead!

I just tried updating OS per Jas's instructions and it died right on step 2 for doing the first thing Bin Lib. only.

Yes, I'm in port 1, yes I just downloaded the latest OS files, and they all matched what Jas had in his instructions.

I was at OS 8.0.1 prior to this!

Running Window XP

Please advise!


Link to comment
Share on other sites

Please try to place the controller into bootstrap mode and use the standard update wizard again, being certain to use the max baud rate of 115,200 and physical port 1 of the PLC.

To Enter Bootstrap Mode:

  • With the power to the PLC turned off, hold your finger down on the touch screen and plug the power in.
  • With your finger still pressed down count for five seconds, then release and tap the screen twice.

NOTE: You can also first place the extracted .UOS file (zip attached) into the folder directory "Program Files\Unitronics\Unitronics VisiLogic_C\Data\Os Vision\V570\OS" before trying


Link to comment
Share on other sites


Good news! The V570's that I thought were dead are not! The problem has not been pin pointed yet, but I'm working on this as I write this reply.

I was able to bring all the dead V570's back to life by changing my normal download speed to 115,200 as mentioned, this is where the speed was at last, before it had crashed during the OS update.

Out of the three I had dead, one of them was on the red screen, that was the easy one to redo the OS update to, the other two that were were on black screens, I had to redo twice, but all is now good.

I have been working with Jas on this via the telephone, as I mentioned to him, I will do a test tomorrow to see if I can reproduce the problem.

Happier now!

Deke :rolleyes:

Link to comment
Share on other sites

Hi Roland,

Are you using VisiLogic 9.0.1?

If you are facing issues with updating the PLC OS then try the following:

• Power off the controller.

• Press and hold your fingers on <i>+<ESC> keys.

• While pressing power on the controller.

• Then the PLC should be in BOOT mode.

• Set the baud rate in VisiLogic to 115200.

• Connect the programming cable to port 1 and download OS again via connection menu --> communication & OS --> OS tab.

• Download your application.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...