Jump to content

errors starting DataXport


Recommended Posts

Hey All,

I ran into a snag this morning, I have a pc whose only job is to run 3 instances of DataXport, and collect data from different processes around the plant and dump them into folders on out network.

Something happened overnight, and my DataXports stopped responding, I got them to shut down, then rebooted the pc.

One of them started up ok, but the other two wont start.

One gives me this error;


And the other this;



Anyone a way to fix these?

Regards JohnR

Link to comment
Share on other sites

  • MVP 2023

I'd first be checking that no windows update etc happened automatically overnight.  Go to the updates list and look at the times of installations.  I'd also check that any run as admin permissions haven't been reset by any updates.  Yes.....I've seen that happen all too often.   Microsoft knows best, not the user, and all sorts of tickboxes get changed back to what they want on even some seemingly minor updates. 

Of course it might be something else, but have a look at this sort of stuff first.

cheers, Aus

Link to comment
Share on other sites

Hi JohnR,

There errors are expected, as only one copy of DataXport may be run under selected account.

Recommended to create a new account for each copy of DataXport.

You have to start DataXpoprt when you are logged as selected user.

This will solve your problem.

*To access running DataXport for different operations - stsrt, stop. configure, you have run it under current account.

When run under system account, you cannot access it anymore.

So you have to kill process, and run it again from logged in account.

This is by design.



Provided by Unitronics free software is intended for small PLC networks, and cannot replace specially developed SCADA programs.


Link to comment
Share on other sites

On 6/30/2019 at 12:56 AM, AlexUT said:

There errors are expected, as only one copy of DataXport may be run under selected account. 

This is interesting, as I have been running like this for several years without issue. I copy the entire DataXport folder and rename it.

It seems more that something has corrupted the  .ulp  as I copied it to another PC and get the same error.

I did some digging and found an archived copy and it started without issue, so I got that under control.

Something else I noticed while dealing with this; DataXport wants to open with the last .ulp it ran (which is expected), but if the last .ulp wont run (as in my case), then DataXport just falls flat on it's face. You would think (that like most programs) it would tell you that the file cant be opened, and prompt you to start a new file.

Just my opinion...


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...