Jump to content

Unistream power meter modbus

John Barry

Recommended Posts


Does anyone have a suggestion to which power meter works well with any unistream PLC?

I've tried a few (Kingsine PCM 72L, Socomec A-20, Enties MPR3) with a modbus RS485 connection.

I have other devices in the dasiy chain that work well, all sessions are successful with no drops except for the power meters. 

Basically i need to find a brand that has the same modbus standard as Unitronics?

Link to comment
Share on other sites

  • MVP 2023

John, I find it curious that many types are giving you trouble.  I just see a link between "power meter" and "drops".  Is the chain done correctly with excellent shielding?  Unshielded sections not near power lines?

As well, are all devices set for comms correctly, with no clashing IDs?  All terminations and resistors located/set/programmed properly? I know these are basics, but often something in a big chain is easily overlooked, or doesn't properly retain a change as expected, and a conflict arises.  Many modbus things I work with annoyingly need a special program to change IDs and retain the change in the initial stages.  Once done properly, normal access is easy.

Of course, the basics of your question are also valid.  But the coincidences are high, hence the questions.

cheers, Aus

Link to comment
Share on other sites

  • MVP 2014

In line with the suggestions by Ausman, have you also tried opering the Modbus with just the power meter and UniStream together, no other devices?

I haven't really seen any issues with other devices not running the same Modbus standard as Unitronics.  One thing I do notice is that different vendors use different notation for the wiring - eg A,B, D+, D- .  I have seen different vendors use opposite notation.  It's easiest to sort this out with two devices at a time, and sometimes the solution is as simple as swpaping the wires.

Also when you get drops, what are the error codes telling you?  Are they timeouts (no comms), or is the power meter communicating, but returning an error code?

My experience with power meters (Crompton, see below) is that they use 32-bit floating point values, but the Modbus address space works on 16-bit words.  Hence only every second Modbus address is valid.  Also beware of the +/- 1 offset.  Unitronics calls the first register as 0, whilst some slave devices call their first register as 0 and others call it 1.  Also if you a trying to read only 1 value, you will need to read two consecutive modbus registers.  If the power meter is using 32-bit values, trying to read only a single 16-bit value is likely to generate an error.

I end up doing a fair bit of experimentation to find the right combination.

Disclosure: My company is a Unitronics distributor and also a distributor of Crompton power meters.  I have set up several demos with UniStream to a Crompton meter and got them working on both Modbus RTU and Modbus TCP.  I have also assisted customers with setting up many different Modbus devices on Unitronics PLCs.

So I could say Crompton meters work fine. However If you can't get 3 other brands to work, then I would be looking at the setup rather than the brand of meter.

  • Like 1
Link to comment
Share on other sites

  • MVP 2023

Modbus is a standard protocol.  Unitronics just implements it, albiet starting the data address pointer at 0.  Otherwise it's the same as everybody else's.

I spent a day with a customer last week with a similar problem - he had 9 devices on an RS485 network and one of them just wouldn't talk to the Unitronics.  I had no problem talking to it over the same network with my Modbus simulator program on my PC.  My simulator allows monitoring the network traffic with time-stamping to .001 second resolution and I was eventually able to determine that the problem child was taking longer to respond than the other sensors.

We fiddled with the timeout and retries on the Modbus config block in the program and got it to work.  If you want to post your program we can have a look at how you've got Modbus set up.  Also post a link to the Modbus table of the device you're trying to talk to with the program.

Joe T.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...