Jump to content

UniDownLoader possibly corrupts evb file


Recommended Posts

  • MVP 2023

@Cara Bereck Levy   @Saragani

Hello all, just a headsup that today in installing UniDownLoader to observe Bisku and Karl's issue, I found that it corrupted the use of the .evb file across everything that uses it.  I had to do the deletion/auto remake/manual refill method on the .evb file to cure the problem.  I could still open Communication-PC Settings, but any connection attempt using a variety of programs brought up the "No PLC is currently selected" error.  I had no problems with connections AT ALL before installing UniDown.  So it would appear that it may have some detrimental impact on the use of the evb.

As a side note on the evb,  I have noticed that some of the ancillary programs do NOT reference it...they seem to go on their own list which is held within the particular program itself.  This can be annoying when you think the evb is the basis for all comms but you find a change or addition needs to be done again.  SD card explorer is one such thing.

cheers, Aus

Link to comment
Share on other sites

  • 1 year later...

This still seem to be an issue.

I am having problems with UniDownloader 5.0.29.

I am using Windows 10. I had an older version of Unidownloader on Windows 7 that worked  but after an upgrade it did not work. Tried to run it in every compatibility mode without success.

 I wanted to communicate with the PLC with TCP/IP. When I clicked to choose a favorite I got a Run-time error.


When I pressed OK I got error 440.


When I tried to enter com settings again I got this error and then I had to close the software to be able to open com settings again.


After I saw this thread I followed the steps Ofir posted and after that the program worked fine.


Some days later I once again had to rename the file because I got the same errors after I changed the PLC Name in com settings.


Link to comment
Share on other sites

  • MVP 2023

Peter, I have not had this occur to me again, but likely only because I haven't been using things that cause it.   I haven't explored how the corruption occurs for obvious reasons, but wondering about 2 things to try.

1).  Perhaps the steps I showed in No. 10 of pinned "Topics almost worth pinning" regarding shifting the direction of the evb file might help.  Here:  https://forum.unitronics.com/topic/5439-hiding-remote-locations-on-your-pc-from-crooks/?tab=comments#comment-21086   My suggestion would be to make a copy of the linked file every time you change a connection parameter.  That way you should have an instantly restorable evb file.  You do the renaming (or delete) fix above, let Visi regenerate the new file, and then replace it with your saved version.

2).  Of course, in theory, as no 1 is simply the same file stored in a different place, you can likely do the "backup" method with the evb file in the original location.  I only run the symbolic links on my portable stuff.  

I think there must still be a fundamental, potentially corrupting hiccouph in the way the evb file is accessed by everything that universally uses it.  If it does it again to you, then perhaps compare the suggested backup copy and the new non-working one.  Send the difference to support for them to explore why it happens.  In looking at my current evb file with Notepad+ there is a whole lot of data after what seems to be just one row of all needed info.  I would guess that one tiny flaw in any of that would likely cause issues.

cheers, Aus

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...