Jump to content

Load from DTI issue


Recommended Posts

Hello,  I'm having some trouble loading a DTI from file.  I get a -5 status (Read File Error).  The table is 150 rows.  The file name tag value was "Recipe Master Table" but when i looked at the files on the SD card in the DT folder the file name was "Recipe_Master_Table" so I changed the tag to that but still get -5 error.  Thinking it was file name related I tried different iterations like "DT/Recipe Master Table" or "DT/Recipe_Master_Table.udtf" , etc but still get -5 error.

For a bit of background, I load the DTI from SQL using a query.  If that fails for some reason i load it from the SD card which was saved to the SD card after the last successful query. The SQL logic all works fine but when i purposely disconnect from SQL to test this function thats when i discovered the -5.

I check the file on the SD card by using the utility to convert it to excel.  File seems fine.  All the data is there.

Anyone have any ideas on what may cause a file read error?




Link to comment
Share on other sites

Issue resolved though i'm not exactly sure how :)

In case it may help others, i loaded the file from SD into the unilogic then downloaded the table values to the PLC.  This way i could attempt to save the DTI to file without overwriting it with zeros.  went online and forced the test bit.  Save worked.  Load did not.  Changed file name so there were no spaces.  Saved worked, load did not.  Changed the start and length settings to 0 and 150 from 1 and 149.  Load worked.

I not sure why the start and length would have mattered or its more likely i have the sequence mixed up and removing the spaces in the file name is what did the trick.  Problem is likely 2FBK.



Link to comment
Share on other sites

  • 2 weeks later...
On 8/25/2022 at 10:43 PM, Gabriel Franco said:

This is the way I use function:


I don´t know if your issue is name related as I only use single word to filenames.

One suggestions: to load the whole table, start from 0 and use "Number of Rows" tag from data table target .

This, SD queries do not work reliably with pulse contacts, I believe the help file indicates something about this as well.  I go a step further and put the reset based on the returned value of the error status output. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...