Jump to content

New UniLogic Software 1.34.192


Daniel_EWW

Recommended Posts

Hi,

there are some interesting new features in this version:
- IO-Link support
- Structured Text editor and the long desired
- Support of opening more then one project on the same PC. (UniLogic Multiple Instances)
I'm looking forward to work with this new functions!

I still missing the folowing:
- Compare function (Online <-> Offline) - Not only that something is different in a function. From other PLC systems I'm used to see the exact difference.
- Software versioning - Export/Import project as ASCII files for GIT versioning (Like Projects developed in VS code.)
I'm wondering if this two features are on the UniLogic developer roadmap and if there is already a release date for this functions?

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

hi All,

i join the discussion...in my opnion the new features that Daniel wrote are really interesting...also, in my opinion, the variables grouping is a real good feature.

for sure I will try this new release in the next project...starting from december/january...for the moment I can say "really appreciated".

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

About software versioning, it's on our roadmap to support text files, I cannot give any ETA though... Making project files test based is the first stage of supporting Git, but it is not the last one.

You still need to handle git in UniLogic (since there people who don't know how to work with it), and you also need to handle conflicts, since having text based files doesn't suggest that common users can resolve conflicts by themselves.

 

Link to comment
Share on other sites

Hi! Questions about 1.34.192:
1. Have been fixed the buttons disappearing after Sync in Quick Sync Mode?
2. Is it possible in new version to turn on the screen again, when it turned off after loading some chenges by pressing a Download button, without the rebooting: the screen is off, PLC and Online are in work, but it is absolutely impossible to manage by a continuous process that must not be stopped.
3. Were you able to cope with the shutdown of HMI at 100% CPU load (and this is in a cycle time of 5ms and without any restrictions on its increase!)?
4. Has the very long waiting time of screens switching after pressing a button been eliminated (sometimes much more than 5s)?
5. Is Quick Sync Mode switching on during online mode still made after rechecks, already made in going to online and it takes the same very much time?
6. Will the pressing of "Sync" in Quick Sync Mode be guaranteed to change the program in PLC in accordance with PC programm? Or sometimes, after downloading and entering in Online, PLC will continue to work according to the old program, and only after Online OFF/ON it will report that the changes have not been loaded?

  • Thanks 1
Link to comment
Share on other sites

1. What buttons disappearing? I'm not aware of this issue, or I might now understanding to which button you are referring. Can you be more specific?

2. @NoamM can you answer that?

3. @NoamM Ditto

4. This problem happens when the screen you are loading / switching to has a lot of elements. You should consider redesigning your HMI Screens, unless @NoamM as a better suggestion

5. There are some improvements in the quick sync + online since version 1.33, but it still verifies the project after entering quick sync, and there are still some improvements that can be done in order to reduce the time it takes to enter quick sync. On a small project, it took 7.5 seconds to enter quick sync mode while online was already active, but when Development mode was active, the time was reduced to 4 seconds, so should consider using it.

On next release, entering Quick Sync Mode, after Online is already active, should be almost instant.

6. It should now work properly. Some issues were found and fixed in the Quick Sync. Please note that some changes that may affect other features (Meaning: not Ladder, C code or ST code) terminates quick sync, since only Logic changes are downloaded.

  • Like 1
Link to comment
Share on other sites

1. Before "Sync" there were pictures, after Sync - there are no them, only holes of the background. Only texts remained. All pictures have been taken from the same folder on PC.

2. Corrected the program. Downloaded it. The screen is black. VNC screen was connected - also is black. Program in PLC works without any problem. Online - is working properly. New downloading - no any information about downloading on screen: it is black. After downloading - screen is black. I did not find any way to switch the HMI on again - only rebut, but it is impossible for continuous process.

3. Look at picture (UNI-82953).

4. Of course, 15" screen has a lot of elements. Some of screens have almost max number of elements.

5. Where can I find a detailed description of All points of the top ribbon (Menu)? Description of the  "Development mode" functions?

6. I am working only in Ladder. Without any "C" or "ST". Another question: is it possible to adjust and monitor the program in Online for C or ST? Is it possible to use Ladder and ST inside one function (in the different NW, like for Siemens)?

Buttons.jpg

Buttons-OK.jpg

ErrHMI.jpg

  • Thanks 1
Link to comment
Share on other sites

1. I'm not aware of this issue, and it was never reported. Did you report it to Unitronics Support? Are you still able to reproduce it with UniLogic 1.34?

I will try reproducing this problem, but I never encountered it.

2. @NoamM Please see reply, and answer other questions in previous posts

5. Well, Developments mode turns off password validation (It works for about 30 minutes, maybe less, from the time of activation, if I remember correctly). By that, the communication of UniLogic with the PLC is faster due to smaller overhead. This is good when you are connected directly to the PLC and you want to save time when using Quick Sync, or when performing Download. You can turn the Development On, turn it Off, or check the status of it in the PLC. 

 

6. No, it is not possible to use ST and Ladder inside the same function. You can call ST functions from Ladder, and vice versa

 

And please explain the pictures you've attached. I assume that you are showing the issue with the missing images,  but what is the second image, and what is the third one?
How is the images problem resolved? by restarting the HMI or PLC?

Would you mind sharing your project, so I can try reproducing the issue with the images? (Can be done through our support)

  • Like 1
Link to comment
Share on other sites

Image-1: a part of screen without buttons after the "Sync".
Image-2: the same part in usial state, with all buttons.
Image-3: the problem "3" with support service number UNI-82953 (downloading corrected programm - a few minets of black screen - and this message on the screen of the panel).
The problem is resolved by the button "Download" in "PLC" without "Sync", but there is a risk of the "problem-3".

I will try to use UniLogic 1.34 in a few weaks on the next object. It is very dangerous to update the system in work by online.

  • Thanks 1
Link to comment
Share on other sites

First, thanks for the colleagues around the globe, for being sincere and honest reporting the issues in this new version of Unilogic.

At the same time,  thanks to the Unitronics Support Team for interacting and providing answers that teach us a lot.

My question is basic:   Does this new version run fine on Windows 11?    Because I need to upgrade my Laptop  (Hardening OS) 

Very truly yours,

Marco (from Guatemala)😀

 

image.png.d175be7070b15f48a04eac7e63202973.png

Link to comment
Share on other sites

1 hour ago, Saragani said:

@Marco Mendoza

Yes, it should run fine. As with other previous versions, some users experience issues with windows 11, reporting wrong sector size, which makes the SQL Server to fail starting.

This issue already has a workaround by Microsoft.

Hi @Saragani

I have noticed with windows 11 that when I download a new version of unilogic the previous versions stops working (clicked to keep previous version).

Also some windows updates prevent the current unilogic version from working.

In both cases the program goes as far as "loading shell services". A fresh install solves the problem.

To go back to a previous version I need to delete the current and re-install the old version.

Probably a windows issue but just wondering if anyone else has found this.

 

  • Like 1
Link to comment
Share on other sites

@sgull
Long story short: It works on my computer. I don't think that the issue you describe is related to Windows 11.

What the "Keep old version" does it copy the files from the old installation to a new location and also copy a some files from the ProgramData into that folder. Then change an XML file inside the old installed UniLogic.

Then it uninstalls UniLogic and installs the new version.

 

Next time it happens to you, tell me, so I can debug it on your computer in a remote session.

 

  • Like 1
Link to comment
Share on other sites

2 hours ago, Saragani said:

@sgull
Long story short: It works on my computer. I don't think that the issue you describe is related to Windows 11.

What the "Keep old version" does it copy the files from the old installation to a new location and also copy a some files from the ProgramData into that folder. Then change an XML file inside the old installed UniLogic.

Then it uninstalls UniLogic and installs the new version.

 

Next time it happens to you, tell me, so I can debug it on your computer in a remote session.

 

Hi @Saragani

I just tried my version of 1.33 rev373 and it has stopped working.

Again I assume that some update has taken place on windows.

Normally I would just re-install or upgrade to the newer version.

Is there something I can check that would help with this issue?

Regards

Denis

 

 

  • Like 1
Link to comment
Share on other sites

On 11/20/2023 at 2:52 PM, VladF said:

UniLogic 1.32.98, 1.33.236,  1.33.373 - no one version works on "W-11 Home one Language" - after installing and start the program: "Loading Components..." for hours. Now I am working under virtual machine W-10.

Installing new version onto W-11 Home one Language. Installing itself is OK. After start - error (hiding behind the main banner). After "OK" - "Loading Components..." for a few seconds and ... That's all. Nothing start program.

Installing into VM W-10 is OK.

UL134_1.jpg

UL134_2.jpg

UL134_3.jpg

  • Like 1
Link to comment
Share on other sites

@VladF

OK, please try the following (Anyone else, don't try this. Each problem on its own):

 

Start command prompt as Administrator

Type in the command prompt:  sqllocaldb delete unilogic

Then type in the command prompt:   REG ADD "HKLM\SYSTEM\CurrentControlSet\Services\stornvme\Parameters\Device" /v "ForcedPhysicalSectorSizeInBytes" /t REG_MULTI_SZ /d "* 4095" /f

 

Restart the computer

 

Then try running UniLogic and tell me if it helped

  • Like 1
  • Thanks 1
Link to comment
Share on other sites

Hello. i got the same problem, Windows11, I just installed the last version (1.34.192) without error messages, but when I try to start the program, the starting crash with the message: Unilogic Notifier does not exist. I have not being able of practice the solution proposed, on the step about change the register, the prompt answer "access is denied". This PC have only one user.,there is no more Administrator session than mine

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...