Jump to content

Version Swapper on Windows 10 problem


Recommended Posts

No matter I run the application under administrator's account on my laptops with Windows 10 (both 32 and 64-bit versions), Version swapper would not function normally unless I specify "Run as Administrator" option as I start the program. Yes, it is possible to specify this option on a shortcut that starts Version Swapper, so it always runs "as administrator".

But, still there is a big problem: even than some older versions would not run after being registered with Version Swapper, there are various error messages that says that some componenets could not be registered, that are missing or invalid. It works normally for some latest versions, I tried 9.5.0 and 9.8.22 lately.  I normally connect remotely with my customer's PLC's  and I need to use exactly the same VisiLogic version in order to verify the program in a proper way before making any changes eventually,  so it is actually a big problem to me. Also, I tried to install the whole package in a folder other than Program Files (X32 or not, depending on Windows), and to change its security properties - everybody has full access rights, but still the same situation.

Any thoughts?

Link to comment
Share on other sites

  • MVP 2023

Starting with Win 7 Visilogic is very picky about being Run as Administrator.  You always have to do it.  The easiest way is to change the property of each instance of Visilogic.exe in each folder it's installed in to Run As Administrator.  Just adding the property to the whole folder doesn't cut it.

A pain in the butt, yes.  But it's the Microsoft world we live in.

Joe T.

Link to comment
Share on other sites

Joe, I suppose you're right about Microft world and stuff...

Unfortunately, even if I explicitly run Swapper as administrator and upon registration of say VisiLogic V4.7.3. I explicitly run VisiLogic.exe in .../VisiLogic_V4.7.3./Main/ folder "as administrator" it still says: "Run-time error 339" - snapshot attached.

Error.jpg

Link to comment
Share on other sites

  • MVP 2023

Hi Sremac,

Every time I have used Swapper with latest versions etc I have found all sorts of errors pop up on opening versions that previously worked ok.  The only way I was ever able to get around things was to uninstall them all and then redo them.  This is tedious but worked.  It is similar in principle to what I suggest in this post at post 2:  

Perhaps you could spend a little time trying this method and see how it goes?

And a PS to Joe....we're getting old aren't we, to remember that!

cheers,

Aus

  • Upvote 1
Link to comment
Share on other sites

  • 10 months later...

Dear Ausman,

thanks a lot,  I've tried your method with partial success. Also it's too complicated, I mean too error prone for an old guy like me...

One new moment concerning W10 and Version Swapper:

After fresh W10 installation I've had the same issue as described above, Run-time error 339, amiTapi .ocx components not registered/missing. I tried to locate the file amiTapi.ocx on my computer without success. But on the other laptop I've found it, made a copy to the USB flash and transfered it to c:\windows\system32   folder. Note 32-bit W10 version, otherwise on a 64-bit version it should be copied on a C:\Windows\SysWOW64 folder.  After that I found regsvr32.exe in the same folder. Then I started command prompt (cmd.exe) as an administrator, and typed:

cd c:\windows\system32\

regsvr32  amiTapi.ocx /s

This was actually the registration of a copied file.

Then I tried to register Visilogic Swapper version with Version Swapper , and get the same message but this time Actbar2.ocx was the problem. I repeated the procedure, exactly the same as for amiTapi.ocx file, and now I have no problem with Version Swapper, it normally works with all Swapper Visislogic versions, downloaded from Unitronics site.

Once again, for W10 64-bit version users, just instead of C:\Windows\system32 folder use C:\Windows\SysWOW64 folder. And thats it. The onlz problem is that one can not be able to find the missing files. They are extremely vulnerable and should be used only if they originate from original Windows installation (usually Resource folder).

Link to comment
Share on other sites

  • 1 month later...
  • 5 years later...
On 8/15/2017 at 8:23 PM, Sremac said:

Dear Ausman,

thanks a lot,  I've tried your method with partial success. Also it's too complicated, I mean too error prone for an old guy like me...

One new moment concerning W10 and Version Swapper:

After fresh W10 installation I've had the same issue as described above, Run-time error 339, amiTapi .ocx components not registered/missing. I tried to locate the file amiTapi.ocx on my computer without success. But on the other laptop I've found it, made a copy to the USB flash and transfered it to c:\windows\system32   folder. Note 32-bit W10 version, otherwise on a 64-bit version it should be copied on a C:\Windows\SysWOW64 folder.  After that I found regsvr32.exe in the same folder. Then I started command prompt (cmd.exe) as an administrator, and typed:

cd c:\windows\system32\

regsvr32  amiTapi.ocx /s

This was actually the registration of a copied file.

Then I tried to register Visilogic Swapper version with Version Swapper , and get the same message but this time Actbar2.ocx was the problem. I repeated the procedure, exactly the same as for amiTapi.ocx file, and now I have no problem with Version Swapper, it normally works with all Swapper Visislogic versions, downloaded from Unitronics site.

Once again, for W10 64-bit version users, just instead of C:\Windows\system32 folder use C:\Windows\SysWOW64 folder. And thats it. The onlz problem is that one can not be able to find the missing files. They are extremely vulnerable and should be used only if they originate from original Windows installation (usually Resource folder).

Digging this one up from the grave;  Could you tell me where you found the Actbar2.ocx file in the first place?  I've got the amitapi.oxc issue sorted (unitronics offer the file under help portal) but now I have the same problem you had but no Actbar2.ocx file to register...  

Link to comment
Share on other sites

  • 2 weeks later...
On 1/31/2023 at 5:13 AM, Joe Tauser said:

This is interesting.  On my system under C:\Windows\SysWOW64 I have both Actbar2.ocx and Actbar3.ocx.

 I have no idea why those files aren't there from the Visilogic installation but here you go. 

Joe T. 

Actbar2.ocx 814.58 kB · 3 downloads Actbar3.ocx 926.81 kB · 0 downloads

Nice work mate - this has resolved the issue.

Cheers,

Sam

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

This site uses cookies. By clicking I accept, you agree to their use.