Jump to content

JZ20-J-T40 Ethernet communication with SCADA

Recommended Posts


I'm using Unitronics PLC JZ20-J-T40, and ZView SCADA.

I have successfully downloaded my program into PLC, and tested communication via usb (Serial), and via Ethernet (MJ20-ET1). It's all working properly.

Problem begins when i try to connect my PLC to scada PC.

With USB everything is working normally, but it's not an option for me to work with usb connection.

I want to work with Ethernet communication between PLC and SCADA.

What should i do to make it work?


Nikola Ljubinkovic

Link to comment
Share on other sites


I contacted Zivan company who is  the supplier of the Zview.

In order to support Jazz Ethernet please try the following:

1. Change the attached file drvlazz.txt to drvlazz.dll and copy it to Zview\bin

2. Change the attached file Zview.txt to Zview.exe and replace in Zview\bin

3. in the project you should select as attached picture.





Link to comment
Share on other sites


I did everything like you said, but it's still not working.

I have 1 Unitronics V130-J-TR20 PLC and 2 Unitronics PLC-s Jazz JZ20-J-T40.

When I set everything like you said, Jazz PLC is working properly, but V130 doesn't .

In attachment i have sent pictures with my settings for V130 and JZ20 PLC, on ZView SCADA.

Just to make it clear, I can establish communication with only one of the two different PLC-s, but when i connect them together, one of them stops working.

Either Jazz is working, or V130, but together SCADA just says port inactive.

Jazz Port state inactive.JPG

DS for V130.JPG

Aliases and IP and DS For V130.JPG

Aliases and IP and DS For Jazz.JPG


Link to comment
Share on other sites

Also, I wanted to add this,

My SCADA license is this on the picture

I have seen that in order to connect PLC to SCADA I need to have specific driver for that PLC on my SCADA usb(License).

When I purchased license, and connected it to V130 (Vision) via Ethernet, everything was working normally, but when i tried to connect my other Jazz PLC, that is when problems has began. 

I contacted you, and you give me driver to connect to Jazz, I pasted it like you said.

Then I realized that Zview SCADA (From Zivan) doesn't have that kind of option (Or in my case).

Anyway, this is what has happened.

V130 has worked normally, until I put this driver you have gave me.

Now eider Jazz is working, or Vision V130.

It seems like Zview SCADA can only use one of the drivers for connecting PLC to SCADA.

When connecting, on the very beginning, SCADA chooses one of the drivers, and that driver is either for Jazz or Vision.

When it has successfully connected to one of the PLCs using one of the drivers, it just won't connect to the other one using the other driver.

It is a big problem for me, is there a way to change some settings on zView SCADA in order to use both of the drivers I have, or there is some other solution?


Nikola Ljubinkovic

Scada License.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...