Jump to content

Recommended Posts


I have made programs for SAMBA PLC SM35-J-T20 and TA22 with Modbus configuration.

In Com init help, it tell me to select RS232 or RS485. But the field is grayed out on RS232 and I can't select RS485.

If I remember right, I could select RS485 when I did the program for the first time, but when I chech the Com Init settings, they all say RS232 and not RS485.

Doesn't it matter if it say RS232? I had to change it to RS485 in Info mode to get communication to work, but if I loose power, it returns to RS232.


Link to comment
Share on other sites

Also, the code looks like this. I'm just wondering if it is okay to place the contacts like that.

When I did an Online test, if I activate MB81 in the HMI, all com init FB's turns red.  If I activate one below, all com init except the first one get red.

Is that normal or is the ladder code not optimal?


Link to comment
Share on other sites

I see, break it up in like one separate Com init + modbus configuration per net?

The Samba need a communication card for RS485 or for TCP/IP. But I want to prepare the program so it supports both. I just found it wierd that I can't choose RS485.  If I choose Vision in HW configuration, I can choose between RS232 or RS485.

Link to comment
Share on other sites

  • MVP 2023

Hi Peter, I just did a trial new project with a Samba and could choose 485 as shown on the scrnshot attached.  This is 9.8.31, though.

Maybe if you are on later versions something has changed to allow for the fact, like Isak says, that Samba doesn't natively have both 232 & 485 like Vision does?  Perhaps try a reinstall? Or use version swapper to test the theory?  If something has changed in later versions, then perhaps there is now a hardware config link to say that the 485 module has been fitted?



03-Mar-18 08.30.gif

Link to comment
Share on other sites

Hello Ausman,

something has definitely changed. When I start a new project in Visilogic 9.8.31 I can choose between RS232 and RS485. In 9.8.64, it is RS232 only.
When I saved the test program in 9.8.31 (RS485 in com init) and opened it in 9.8.64, com init said RS232 and it was grayed out.
I'm stuck with 9.8.64 because all my recent programs are made in that version and can't be opened in an earlier version.
It seems though as if the PLC recognise the com card as RS485 when I run the program in a PLC with an installed Modbus card.

Can someone from the development team answer if there has been a change in the program that affect the com init block for Samba PLCs?

Best regards

Link to comment
Share on other sites

According to tech support, there was a bug in Visilogic 9.8.31 with the Com FB that they fixed in 9.8.64.
I got the explanation that it was not possible to choose RS485 in the older version but that it now is fixed.

It seems as if the bug was present in 9.8.64. I tried the same thing with 9.8.65, and now it is again possible to choose RS485.

Also programs made in version 64 that showed a grayed out RS232 com init setting, do show RS485 again in version 65.



  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...