Jump to content

Problem with Visilogic software

Recommended Posts


I have problems with Visilogic software,  when I'm in online mode. I'm unable to do online test, because every 1-2 minutes online is interrupted with message attached in this post.

After confirming with OK, Visilogic shuts down itself. This makes big problems to me because I'm unable to test my software, as it has much timers which I must to monitor.

Visilogic version: 9.8.90 Build0 (also happened with previous version)

PLC - Samba SM35-J-R22

NOTE: I don't know if this can make problems, but PLC is on 100% memory usage (no free space). I have tested for now on 15+ pcs of this Samba, and with every PLC I have same problem.

I didn't noticed earlier this bug, when PLC memory wasn't so full.

I have tried to uninstall/install Visilogic but with no luck.

Any help is welcome.



Link to comment
Share on other sites

  • MVP 2023

I've never encountered this situation, but I would contact Unitronics support directly. This error message looks to me like VisiLogic is out of memory, not the PLC. Is there some special situation with your PC that might result in insufficient memory space for VisiLogic?

Link to comment
Share on other sites

  • MVP 2023

Flex is correct in that Support is likely best, but in case you haven't got onto them yet, what happens if you install Visilogic on another PC etc that has never had it? 

Did you do the install as Right click/Run as Admin?  After installation also confirmed the installed .exe is set to Run as Admin as well?

What is using up the PLC memory?

What happens if you use info mode on one of the Sambas to completely  reset it?  ie no program at all.

cheers, Aus

Link to comment
Share on other sites

PC memory is not problem, when running Visilogic it's used under 20% of 24gb.

I didn't used installation metod "as admin", but I must admit, I have never use that metod for Visilogic before, and also never experienced that problem like now.

For start, I will now unistall and install it again with Admin privileges.

After that I will try empty Samba, and I will inform you about result.

Thank you very much for tips!


Link to comment
Share on other sites

  • 2 weeks later...


back to this problem. I have tried new clean install of Visilogic (as Admin), but nothing happened. Then tried Samba on other computer where I know for sure that Visilogic doesn't make problems, and I got same memory problem when I try to run online mode with this software uploaded on PLC.

Though i didn't think, the problem was definitely related with PLC memory...

So, your suggestion is to contact Support?

Thanks again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...