Jump to content

V570 TCP-IP Scans not getting some data

Recommended Posts

Good Afternoon

I have a V570 that is connected over TCP/IP to 2 cognex cameras. for some reason that I cannot establish when I start the system, the first 3 or 4 scans will not trigger the scan. Neither MB33 or MB38 go high when the camera is triggered to take a picture. After the first couple of scans it seems to start working properly. The logic in my head tells me that the camera for some reason isnt sending the scans over properly, but that doesnt make sense to me either. This is the initialize in the main routine.image.thumb.png.7c6df9dbfed469b67705bcb8629604ba.png

If I go to the sub routine (and yes it is being called) if the positive edge of MB33 or MB38 is not seen, the whole system stops.

I have to be missing something, I have time outs set, so If I lose communication for some reason is starts again. I am missing something and hoping a genius out there can assist my brain






Link to comment
Share on other sites

  • MVP 2023
3 hours ago, DaveE said:

the first 3 or 4 scans will not trigger the scan

I guess you are meaning the first 3 or 4 scans of the cameras?  Not the plc?  (which would be a pretty quick production line!)

Without looking too closely, you have a lot of different stuff going on in some rungs/nets.  I would be splitting things up a whole lot more and only doing a particular type of action in one rung.  By the sound of it actions are needing to occur before it all settles....... have you tried the old chestnut of things slightly out of order, such that rearranging the same elements in the sequence can fix the issue?  Humans are very good at missing this bit, but the plc only does what it is told!

cheers, Aus

Link to comment
Share on other sites


Yes you are correct scans of the camera (slip of the brain)

The issue I have is that even if I just stay on the first 5 lines of the main routine, and dot run anything else at all, the MB33 and the MB38 do not increment to start with, and then "wake up"

(Those are attached to the TCP/IP scan)

One thing that was suggested to me today, which I forgot about was to go into info mode and scan then, to see if the PLC is getting something and doing nothing with the data, or not getting anything



Link to comment
Share on other sites

  • MVP 2023

Is it possible that socket1 used in application - also as default used for Visilogic connection (internal)?

Then sw. to camera takes some time.

Described behavior looks like USB port 1 used when Modbus on com port1 configured... After USB disconnect - some times needed for port go to modbus mode.

Please try with different socket.

Link to comment
Share on other sites

  • 1 month later...

Just if anyone cares, I fount the issue

The socket was going to sleep after the time outs ended, and it took a while to wake them back up again

I set them to the maximum and it still wasnt enough, I ended up having to set the time outs to 0 and then I always got the data coming in.

Not the way I wanted to do it, but hey it worked


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...