Jump to content

USB To Ethernet Adaptor


CatUnitronics

Recommended Posts

Had a USB to ethernet adaptor that was working and something else with higher priority happened and was taken from the computer cart. Was informed that it was replaced with a new USB Adaptor.

Went to collect data from the USB-156-B10 and would not work. Came to my desk and got the one that I knew worked and this did enable to get online with the unit. What is possibly missing?

 

Thanks

Link to comment
Share on other sites

  • 3 weeks later...
On 12/14/2020 at 6:03 AM, Swervomotor said:

Your PC could be missing the driver for the usb to ethernet adaptor , or did you check the IP and subnet on your laptop (assuming) so that it was on the same network as the PLC (eg 192.168.x.xxx).

Swervomotor,

I believe that the PC was missing the new adaptor drivers. I was able to get the data collected like in the past method and the original USB adaptor is no longer working. When you download the program with the original USB ethernet adaptor, are you allowed to use a different USB ethernet adaptor to get online and communicate with the server application? 

Does using a different USB ethernet adaptor other than the one that was used for downloading have an effect on the Unistream?  The issue with not communicating to the server started when someone put a different ethernet adaptor. 

Cat

 

Link to comment
Share on other sites

  • MVP 2021
14 minutes ago, CatUnitronics said:

Does using a different USB ethernet adaptor other than the one that was used for downloading have an effect on the Unistream?

I can't imagine that the PLC would have any idea what the source of the Ethernet signal is and I don't see any way that there would be an effect on it. However, if you're not careful UniLogic can change certain communication parameters during download which could disrupt future communications.

Link to comment
Share on other sites

25 minutes ago, Flex727 said:

I can't imagine that the PLC would have any idea what the source of the Ethernet signal is and I don't see any way that there would be an effect on it. However, if you're not careful UniLogic can change certain communication parameters during download which could disrupt future communications.

Thank you Flex727,

Did not know the UniLogic can change certain communication parameters during the download. I do not recall downloading to this unit. I will have to look and see if it was downloaded to without my knowledge. I do know where to see when the last download took place.

Link to comment
Share on other sites

50 minutes ago, Flex727 said:

I can't imagine that the PLC would have any idea what the source of the Ethernet signal is and I don't see any way that there would be an effect on it. However, if you're not careful UniLogic can change certain communication parameters during download which could disrupt future communications.

Flex727,

Looked in About and was not downloaded recently and looked at the software signature and not able to see if there were changes made. I do thing that by downloading all may possibly help. The problem with that is they are running the unit and do not want to try it as I may make a mistake and have it be down. Going to get the one set up on my desk and when correctly, will swap it out.

Link to comment
Share on other sites

Check the Panel IP address and program version number in UNI APPS by press and hold the top right corner of the HMI,  Make sure your IPV4 IP address under network settings on your laptop for the USB network adapter is on the same subnet eg( if HMI is 192.168.1.20, then you should be something like 192.168.1.30 with the same subnet mask eg 255.255.255.0)  Make sure you are using the same version of Unilogic that the project was downloaded with by confirming in UNI APPS the software version.  Lastly make sure you are on the same physical network, if you go through switches to get to the machine are they actually connected?

 

-Swervomotor

Link to comment
Share on other sites

On 1/4/2021 at 5:45 AM, Swervomotor said:

Check the Panel IP address and program version number in UNI APPS by press and hold the top right corner of the HMI,  Make sure your IPV4 IP address under network settings on your laptop for the USB network adapter is on the same subnet eg( if HMI is 192.168.1.20, then you should be something like 192.168.1.30 with the same subnet mask eg 255.255.255.0)  Make sure you are using the same version of Unilogic that the project was downloaded with by confirming in UNI APPS the software version.  Lastly make sure you are on the same physical network, if you go through switches to get to the machine are they actually connected?

 

-Swervomotor

Swervomotor,

Thank you for your input. Things checked out good with the IP addresses and Mask. Versions of UNI APPS do match. Went to collect data this morning and was able to communicate with the server application like it had done in the past when working correctly. I am thinking that there is something interfering with the unit. Noise issue?

CatUnitronics

Link to comment
Share on other sites

  • MVP 2021

Cat, you might possibly have to have a good read of the following, and maybe all the topic to get background.  Although seemingly unrelated to your issue, if you go down the path of removing ALL drivers associated with any adapters by using the mentioned program, and then start again from scratch, it might cure the issue.  Again the warning that the tool mentioned is very powerful and needs to used carefully.

cheers, Aus

https://forum.unitronics.com/topic/3454-usb-rs232-adapator-erro/?do=findComment&comment=12671

 

Link to comment
Share on other sites

On 1/5/2021 at 3:02 PM, Ausman said:

Cat, you might possibly have to have a good read of the following, and maybe all the topic to get background.  Although seemingly unrelated to your issue, if you go down the path of removing ALL drivers associated with any adapters by using the mentioned program, and then start again from scratch, it might cure the issue.  Again the warning that the tool mentioned is very powerful and needs to used carefully.

cheers, Aus

https://forum.unitronics.com/topic/3454-usb-rs232-adapator-erro/?do=findComment&comment=12671

 

Went to collect data like I have in the past and the server application was seen by the adaptor and began collecting the data. We were shutdown and I am not sure if the system had been powered down. It may be that the system needed to be re-booted. The drivers may not have been properly installed when I tried the new adaptor and caused an issue. I believe I know what happened, but not exactly sure how it got corrected. I thank you for your words of wisdom.

Cat

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...