Jump to content

Problem with connecting with Vision 280


Recommended Posts

Hello all,

I have brand new Vision 280 FW Version 5.04 and Visi Logic 9.8.96  (Yes, it is quite old plc  FW but I have to connect on it with SCADA to take some data for the central visualisation).

This is spare plc for the one installed on the line and I have to acces to it. Now I am trying to connect on the new plc without application on it using Port1 (RS232) , cable MJ10-22-CS25 and USB-Serial converter which I am using a long time so I dont expect problem there. All comm parameters should be set well (57600, 8, None, 1), on the plc is same. 

When I go on CONNECTION -> Communication & OS - > Get PLC Information, I have message > "Communication Driver Error (206) "

image.png.d7712667ee7c055bb90c0d18a7cc84c1.png

 

As i am new in Unitronics, can someone give me advice what to do? Tried to find older version of the Visi logic (5 OR 6) but there is no on site and wrote on support email last week but nobody answered.

Thank you in advance.

Link to comment
Share on other sites

@AlexUT Thank you for the answer. Tried but it is the same. 

First I tried to make my own cable with RJ11 port but now have brand new from the supplier so this should be ok. 

When I hold "i" button on the panel, enter in Settings menu, I see that parameters of the Port 1 are 57600, 8, None, 1. After your message I tried to change it on 7, E, 1 (on my laptop and config of the connection in VisiLogic as well) but no solution...

 

Any other suggestion?

 

Thank you one more time

 

Link to comment
Share on other sites

VisiLogic use PCOM (proprietary) protocol with communication parameters 57600, 7, E, 1.

Even if COM port is set to 57600, 8, N, 1, after detecting PCOM protocol PLC change communication parameters to 57600, 7, E, 1 for near 60 sec.

Check if Rx&Tx wired right.

Link to comment
Share on other sites

22 minutes ago, AlexUT said:

PCOM (proprietary) protocol with communication

All looks OK for me, cable is new and delivered from Unitronics, anzway problem existed with cable I made according instructions from manual.

 

Can some Software version be a problem? 

 

Thank you

 

Link to comment
Share on other sites

Does V280 display works/lights?

Press I button - does PLC enters INFO mode?

If you use USB-to-Serial adapter - do you see linked COM port in Device Manager?

*PC COM port number should be between 1 and 16.

Are you sure gray 4 wires cable crimped properly?

2-5, 3-4, 4-3, 5-2.

 

Link to comment
Share on other sites

1 hour ago, AlexUT said:

Does V280 display works/lights?

Press I button - does PLC enters INFO mode?

If you use USB-to-Serial adapter - do you see linked COM port in Device Manager?

*PC COM port number should be between 1 and 16.

Are you sure gray 4 wires cable crimped properly?

2-5, 3-4, 4-3, 5-2.

Yes, I can enter in INFO mode. There I see that PLC is in RUNNING state (Tried to stop it also).  Also cheched Comm parameters there. 

There I found in Model & OS menu: Vision2xx O/S, v5.04 (B64) HW: A  and below state RUNNING

Regarding setup of the adapter in Device manager all is same as in the PLC and of course port is appropriate, with the wrong port message code is 207 and it is immediate, in my case I see on the converter LED that Tx signal is active but there is no reponse from the plc and on the end Timeout Err occurs.

I see in System Mode option "Init", should I try to initialize PLC? I suppose there is nothing bad to do it on brand new plc without any app on it.

 

Thanks

Link to comment
Share on other sites

  • MVP 2022
2 hours ago, Milos said:

I see in System Mode option "Init", should I try to initialize PLC?

Initialize merely clears out all operands (assigns the value zero to numeric operands and resets bit operands to off). Normally, this will not affect communications, but will not hurt anything. If the running program has power-ups, then that power-up value will be assigned immediately when the PLC returns to run mode.

Link to comment
Share on other sites

  • MVP 2022

Gariel has just replied as I write this, with a point I was typing!  Also, the usb adapter must use a Prolific chip.  From what you have said, I gather that you use the same adapter to connect to the PLC on your "line".  Check that the link is working with this unit ok, and if it is, use info mode to find comms settings.  Can you get anything out of the plc when you simply do a Get OPLC Information from the Connection/Communication & OS.

If all else fails, I'd be doing a full reinstall of OS etc, that matches what your unit on the line.  Don't upgrade for no good reason, it might create big headaches.

cheers, Aus

Link to comment
Share on other sites

If a Tx LED of USB to Serial converter lights but Rx not - I am pretty sure in one of 2 things:

1. Rx/Tx wires may be swapped.

! Unitronics supply 4 and 6 wires cables crimped as 1-6, 2-5, 3-4, 4-3, 5-2, 6-1.

If you by mistake use regular phone cable, it may have the same gray color, but crimped 1-1, 2-2,... etc.

Or used cable may have 2 wires.

Or crimping is not good - bad contact.

 

I recommend to check the same adapter-cable-etc. at other PLC to be sure it works as a kit, than return to V280.

If PLC is pre-programmed - COM ports may be initialized for other communication parameters and may be in use.

1. Power-on PLC when pressing I button.

PLC will start in STOP mode.

2.Check communication.

 

For USB to Serial adapter COM port:

image.png

 

image.png

At next picture should be information about driver for your USB to Serial adapter:

image.png

In Device Manager select "Menu->View->Show hidden devices" and check that:

1. COM port you use is not assigned for other device.

2. COM port number is in range 1-16.

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...