Jump to content

Communication issues (over USB)


Recommended Posts

Hi all,

I've been programming a UniStream PLC for a while now and have had to now install it in another room. I has always (as far as I remember) been fine programming it here on this desktop PC (Win 8) but now I've had to move the PLC to a test room I've had to try and program it over USB using another computer (a Lenovo Yoga notebooky-laptop type thing running Win 8.1).

I've installed the UniLogic software as before, even uninstalling and reinstalling again, making sure I installed the second time using "Run as Administrator" on the installer, in case that didn't allow something to install properly the first time.

With both the first time around and second time around install, the programs all load up fine and everything else looks the same as it ever did on the version I have on this desktop PC (the latest version, Ver. 1_9_Rev_19), but I can't get my laptop to connect to the PLC.

I have tried things I've found on this forum, like: powering off the PLC and trying again; powering off the PLC, unplugging the USB cable, closing UniLogic, killing the Unitronics Notifier (via the Task Manager), restarting UniLogic, powering on the PLC, and after the PLC has booted, plugging the USB cable back in. I have tried all kinds of combinations of these things, multiple times, and still ahve had no response from UniLogic when trying to connect to the PLC.

Sometimes (though rarely, compared to my desktop) it comes up with the message about connection problems ("Connect PC to PLC ... If a PLC is ... not discovered ..." etc.) in the PC-PLC Communication window, but when I press the Refresh button/hyperlinklink, where it usually says (on my desktop) "Searching for hardware. This may take a few minutes, please wait...", for maybe 5-10 seconds and then finds the PLC, on my laptop it immediately returns to the "Connect PC to PLC ... " message, as if it has definitely and quickly not found anything.

The behavior seems very definite about not finding anything. There are 2 USB ports on the laptop; one is USB 3 and one is USB 2. I have tried all of these things in both ports, several times. with restarts in between and everything else I can think of. Please help,. I don't wan tot have to move this desktop computer to the PLC, as there's no space to use it in the test room!

Link to comment
Share on other sites



Please try following these exact steps to initialize communications over USB in UniLogic.


• Please try to power OFF the PLC
• Close UniLogic
• Unplug the USB cable
• Make sure the PLC is grounded (power supply for notebook)
• Power ON the PLC
• When you see the "initializing" green spin logo, plug the USB cable
• After the PLC finished to Boot up Open UniLogic and try to download the project.
• If needed, In the discovery window click on the "Refresh" link few times
If it didn't helped please try to install the driver manually, the path is C:\ProgramData\Unitronics\UniLogic\Drivers

Below you can download the content from this path.


Please ensure you set your Windows operating system to support unsigned USB drivers, as this is a requirement for Windows 8/8.1.


Let us know if this helps.  If the problem still persists, please contact support@unitronics.com for further troubleshooting.

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

I'm having the same issue with a Surface 3.


Same issue, the PC I do work on is difficult to carry into to shop.


Tried disabling driver signature enforcement. No dice.


The link for re-installing the driver is dead.  Is there a new link to download the driver?

Link to comment
Share on other sites

  • 3 months later...

Hi, we have successfully managed to get the driver work on Windows 10.

Please open the device manager (while the PLC is disconnected from the computer).

Expand both "Network Adapters" and "Ports (COM & LPT)"

Now, connect the PLC. Was the PLC added to the "Network Adapters" as "Unitronics Unistream USB Ethernet/RNDIS Gadget", or was a Serial Com Port added to the Ports?

Windows 10 might recognize the PLC as a serial port, which in this case, the driver should be browsed specifically, while the signed drivers enforcement is turned off.

  • Like 1
  • Upvote 1
Link to comment
Share on other sites

  • 5 months later...
  • 7 months later...
  • 6 months later...

I've been told USB on Unistream is a virtualized ethernet adaptor. I found that AVAST firewall was blocking USB connectivity but not ethernet when using my laptop on UniStream15.6. Turning third party firewall off allowed USB connection to work. This was on a laptop, Win 7 pro 64 bit. My discovery may not have any relevance to the issues being encountered o this thread but is an easy thing to try. I've also seen AVG FREE interfere with serial communucations to CAC card readers. Spent hours fidling with drivers to only find it's an AV problem.

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...