Jump to content

remote operator


Recommended Posts

hello, i' m Bruno, a french user.

I'm using a V130-33-T2 with a bluetooth card V100-17-BT1.

This connection is used to manage PLC without wires, and i would want to use Remote Operator with a PC OS Windows Seven 64 with bluetooth port.

But it doesn't work, i can't connect to the PLC, It says " Specified Serial Port doesn't exist ".

It works correctly on Remote Access with this configuration but Remote Operator offer to my client a bigger screen of the PLC front.

Note that its works very well with cable serial connection on all PC OS (XP, Vista or 7), and with bluetooth with OS (XP and Vista)

The only case where it doesn't work = bluetooth with Windows Seven 64, i dont have try witth Seven 32.

Thanks for your help.

Best regards. Bruno

Link to comment
Share on other sites

Ok, our support says that they helped another customer who encountered a similar problem with Windows 7, BlueTooth and one of our .Net based applications (Like Remote Operator).

They say that turning the UAC off and Unsetting the c:\Program Files (x86)\Unitronics\ readonly option (Make if from ReadOnly to non-readonly) solved the problem.

Please note that after turning off the UAC, you must restart your computer.

Link to comment
Share on other sites

Hi, do you have a Visual Studio in your computer?

I'm wondering if you can run the following code and tell me it's result:

string[] portNames = SerialPort.GetPortNames();

foreach (string portName in portNames)





SerialPort requires:

using System.IO;

If you won't have Visual Studio then tell me and I'll code a small Exe for you that will show those results.


Link to comment
Share on other sites

Hi, I saw it.

The previous version of the exe I have you was compiled using .Net 4.0 and the current version is compiled using .Net 3.5

In the first version, the port names returned by your system where like COM1, COM2, ....

With the new version it is like: COM1?, COM2?, ... (An extra "?" is being added in the end of the string).

This implies that the problem is not with Remote Operator itself but with .Net 3.5 (It probably has a bug related to 64 Bit os and/or non-English systems).

You can try changing your regional settings to English. It might solve the problem.

Beside that... I assume that you cannot even connect using Serial Cable and Remote Operator on Window 7 x64 since it should fail on the same reason. Am I correct?

Please note that I need to compile a new version of Remote Operator and all of it's dependencies in .Net 4.0 so it might take a while.

I will also search the Internet for the specific problem where .Net 3.5 fails to get the correct serial port names from the OS.

Thanks again for your feadback.

Btw, If you do try changing your regional settings then please update me if it worked or not.

Link to comment
Share on other sites

Hi, I can verify that it is a problem with .Net 3.5 or with the Bluetooth driver. See here:




You can try updating your Bluetooth drivers (Maybe it will work).... Btw, Changing the Regional settings will not help you in this case cause the problem is reading values from the registry. (Normal serial ports strings end with a Null while Bluetooth strings don't, so an extra character is being read from the registry binary file).

I now understand why regular ports works fine (Because this bug only appears in BlueTooth ports).

Link to comment
Share on other sites

  • 6 years later...

Hi there!

I have the similar problem;

Im using internal bluetooth module inside my laptop. I created virtual serial port in the laptop( COM10and COM11 ).

I have some bluetooth   device which have serial DB9 connector and if I connect it with my virtual serial port it can be used as a serial connection without wires.

If I put that DB9 connecto for example to another PC I can freely comunicate over serial bluetooth.

I tryed to conect to V 570 but it doesnot work (well, it works sometimes maybe once in 20 trys.)  I think problem is when i hit "download " button on Visilogic screen virtual port need some time to open (aproximately 2 seconds) and seems that visilogic doesnot wait that long  and since it does not se port open it complains like on the screenshot atached.

Is there any way to overcome this problem since I would realy like to ghet rid of some cables.


Link to comment
Share on other sites

  • MVP 2023

Virtual COM ports are very finicky.  I've tried several and the only one that works reliably is a USB converter with the Prolific PL2303 chipset.  It has to do with when the driver finally gets the operating system's attention - we didn't have to deal with this back in the day when serial ports were on the motherboard and had their own interrupt.

Try Flex727's suggestion - if that doesn't work you're going to have to get a regular USB to serial converter.  With wires.  Sorry.

I've had much better luck with wireless Ethernet bridges, but that does require putting an Ethernet port in the PLC.

Joe T.

Link to comment
Share on other sites

I tried to change "time out setings" but no difference. 

I think  "time out setings" are for the case when port is already opened but client does not respond in the given time frame.

In my case I think Visilogic  does not sense that port is opened and it asumes that it is already opened by other program. I think this is because the created virtual port need some time to "load itself".

As I understand Visilogic opens com port when you click any of : upload , download and monitor function.After it finishes with function it closes even if visilogic is stil runing. So even if Visilogic is runing and you do not use any of functions above you can use port for any other programm.  This opening and closing of port is my real problem.

Anyway guys than you for respond , I will spend some more time on it and if I find a solutionI will share it with you cause i think wireless work is a luxury by itself and getting rid of some cables is always welcome.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...