Jump to content


Recommended Posts

Dear all,

i am new user of UNITRONICS products. I would to introduce myself in Visilogic programming, and i bought SAMBA V43-J-R20 for testing.

I have  air srew compressor and i want to make a plc program for it. I will use four digital inputs, two analog current input and four or five digital outputs.

I  was make a screen objects in HMI  with some text and the first problem is when i download project in PLC the text objects is invisible on the screen.

First picture in attachment (samba1)  is from my LAPTOP, and second picture (samba2) is from SAMBA screen...

I don`t know where the problem is...

The version of Visilogic i use is 9.8.31 build 0, and SAMBA OS is 4.3(06), boot 2.2 (44)...

Visilogic is running on win 10, connection is with USB cable and Serial emulation port.

can enyone help me with this problem??




Link to comment
Share on other sites

  • MVP 2023

Unfortunately, I don't have a Samba available, so I downloaded the program into a V700. Everything showed up perfectly, so there is nothing wrong with your program. I suggest the following:

-Re-download the program fully. I would pull the power and the battery from the PLC for at least 20 min, then replace both and perform the download.

If still the same, then check the status of the firmware by pressing Ctrl-F9 and going to the 4th tab over and press the "Check" button. Upgrade the OS if it says to and repeat the above.

If still no improvement, contact your distributor or email support@unitronics.com.

I have seen this type of thing before (very rarely) and it was usually some glitch that never repeated once the program was re-downloaded.

Link to comment
Share on other sites

Hi Streamer

Try downloading the latest version of visilogic.

When I tried to open your program it said it was made with an older version.

If the Samba is new the operating system installed may be newer than your visilogic version,

This may cause problems with compatibility.




Link to comment
Share on other sites


 Follow the below steps that show how to solve this font issue.

 Go to Help > Check for updates > Operation system to update the O/S files.

Open a new blank project (HW Configuration only)

Go to Connection menu >Communication and OS > 4th tab > Check > Download

When it's done updating the PLC's system files, Add a new font. (Any Font)

To add a custom font type and size in VisiLogic, go to the font handler and add new font.

For more information please go to VisiLogic>Help (F1) Home > HMI Displays > Text > Font Handler

Download All & Burn the project to the PLC.

Then, open your project > Perform Build-All from build menu > Download All & Burn.


I hope it helps.

Link to comment
Share on other sites

Dear ms. R.MOZES,  

thank you verry much for your help, this was solve the problem....  Now i see every font after downloading the project... 

I was try everything else, firmware updating, OS, downloading newest visilogic, and nothing helps.... 

I am happy now,   Thank s again....


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...