Jump to content

Frequency output problem with smaller VFD

Recommended Posts


We have been using the larger version of UMI-B1 EU Series with great succes, and now we are trying to use the smaller version, but we are having some trouble with the frequency, not corresponding to the value sent from the PLC. (V350-J-TA24) communication RS485, baud rate 19200, no parity check. PLC jumper is set to RS485 communication.
I can see that the PLC is both recieving and transmitting data, and we are able to start and stop our Unit with the signal. When we turn on the Unit, and need to increase the frequency, then it just settles between 7-8Hz on the VFD. I can see from VisiLogic that the value the PLC requests is higher, but still the frequency on the small VFD stays between 7 and 8Hz.

Max is set to 80.00Hz

Excact same setup works with the larger version of the VFD, so I assume that we either made a mistake with the wires or it is some setting on the small VFD that has not been set. I have been through the settings many times, and the small VFD is set to the same settings as we have on the bigger one that is working.

Anyone have any experience changing between the two models?
More information can be provided, if needed :) 

Hope for some help, we are a bit stuck right now.

Big UMI-B1 EU series.jpg

Manual used.jpg

Small UMI-B1 EU series.jpg

Link to comment
Share on other sites

  • MVP 2023

Please note small VFD maybe use vector conrtol mode.

Bigger maybe use simple U/F constant mode.

To solve problem:

- check mode used in small VFD;

- change mode for U/F constant and try to start via communication;

-do not change mode but prepare correct motor settings and run autotune via panel or terminal - then check control via communication.



Link to comment
Share on other sites

  • MVP 2023

Yes you find correct  parameter P00.00

For test please set

2: SVPWM control
2 is suitable in applications which do not need
high control accuracy, such as the load of fan
and pump. One inverter can drive multiple

After you can see this note
Note: Motor parameter autotuning is required
when vector mode is applied.

Then if  0 o 1 set is selected in P00.00 - you MUST enter motor nameplate parameter in to P02 parameter group and set autotune bit P00.015.

Please  read about Autotune metods 1 - rotating (for motor stand alone) and 2 - static (if motor cannot de-couple from the load).

Link to comment
Share on other sites

  • MVP 2023

An inverter is not a PLC! It is not possible to simply replace the inverter and the motor to get the same result.

You should understand that the vector motor operation mode is set in the inverter by default (P00,00=1 ) . This mode involves building a virtual model of the motor to create a control vector at the three-phase output. The model includes engine parameters from the nameplate and additional parameters that the inverter can measure in tuning mode. If you switch the operation mode in the small inverter to 2 (this is the simplest mode without current vector generation), then there will be no need to generate the motor model.

And if the inverter and the motor are in workingcondition, then everything should start working (on the same PLC setting).

Next, you follow the path described by me above - adjust the motor parameters and perform auto-tuning.

P.S. When sitting in a car of different sizes, you must adjust the height of the seat and the distance to the steering wheel. Now you are in a situation where you changed the car to a smaller one and for some reason you cannot see the road... You are definitely sure that you know how to drive a car. Just adjust the seat - the car is in good condition :)

  • Haha 1
Link to comment
Share on other sites

  • MVP 2023

Unfortunately, I cannot assess your problem remotely.

However, there are standard engineering approaches to problem solving.

Therefore, I ask you to work out the following steps and give me the result of these steps.

1. Reset the frequency converter to factory settings. P00.18=1

2. Start the engine using the start and stop buttons.

3. Change the frequency from minimum to maximum via panel keybord.

4. Observe the behavior of the motor. If you have the problem of 7-8 Hz again in manual control -


Please send quastion to support@unitronics.com about motor autotuning process.

Link to comment
Share on other sites

Problem solved. A bit unexpected, but apparently the larger VFD and smaller one does not require the same settings for termination.

I moved the jumpers to OFF, to set termination and then the smaller VFD worked as well. 

With the larger model this change hasn't been required. 

Thanks for help and suggestions.


Link to comment
Share on other sites

  • MVP 2023

So, after conducting an experiment with manual control of the VFD, you came to the conclusion that it is in working condition.

Now it remains to find out how the two VFD differ converters.

Unfortunately, in the documentation for your Unitronics inverters,


there is absolutely no mention about turning off and on the terminator for the 485 network in VFD.

The mention of J5 is only in figure 3-9 and it  is not correct .


@Cara Bereck Levy

Please help add and correct the information about the 485 network terminators in the UMI VFD manuals.




The lack of this information is probably the cause of the problem described in this topic.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...