Jump to content

Vision120 showing Black Screen. Not communicate with LAPTOP via serial RS232.


Recommended Posts

Dear Respected Sir/Madam,

During the routine maintenance, I was taking project backup from PLC Vision120 after completing uploading PLC went to reboot after rebooting PLC did not communicate properly. So we are going to change this PLC due to no easy solution available to the following issues.

I have Vision-120 PLC software VisiLogix. I was facing the serious issue that I have mentioned below with pictures;

-We upload the Vision-120 PLC program via Visilogic software. The uploading method was successfully done but after the uploading program, we shut down the PLC and our Laptop for Lunch. after that, I powered the PLC ran the Visilogic app and tried to go online but the PLC did not communicate with the Laptop and also showed a dark screen. After several times tried then I decided to Initialize Reset.  After struggling PLC communicated with LAPTOP only for initialization reset mode picture is attached.  

After completing Bootstrap which shows during initial rest time. After completing this process we tried to download the Uploaded program so the other pictures attached further issues found at the time of downloading.

Please I am very very disappointed about this PLC. Kindly give me the best solution on how can i redownload the uploaded project BKPUP. Hope you understand after checking the attached pictures what is the actual issue?  

Best Regards,

Hasan Haider.

shhz2005@gmail.com.

WhatsApp Image 2023-09-04 at 11.21.50.jpeg

WhatsApp Image 2023-09-04 at 11.22.22.jpeg

WhatsApp Image 2023-09-04 at 11.22.23.jpeg

WhatsApp Image 2023-09-04 at 12.27.39.jpeg

Link to comment
Share on other sites

HI;

Last Image diplays an important point  -- Battery is LOW   -- Change the Battery    

      Battery   CR2450

Remove the connectors, then the back then the I/O Board.

Install fresh battery, reverese process.

Power up, check communications - COM 1   57,600.

Cannot communicate?   screen  works - use Info Mode to check COM settings.

Does your program modify COM Settings for a device?    Have you changed them?

 

Battery Life -- typical 5-7 years - keeps RAM Alive when powered off !!

SI 7      Controls Screen Contrast on the V120

SI 9    LCD Backlight  Intensity

 

DanT

 

 

 

 

 

Link to comment
Share on other sites

 

Dear DanT,

COM 4 is already set and Buadrate is 57600 set. I changed the Buadrate from 57600 to 19200 due to not communicating. Please see the attached pics.
 V120 display keypad not working.  I checked V120 battery successfully battery shows 3VDC. 

I do not understand How can i declare V120 PLC has been faulty.

Please guide me on what can i do?

 

20230823_125916.jpg

20230823_125919.jpg

20230824_111800.jpg

Link to comment
Share on other sites

  • MVP 2023

1).  The comment re the battery being low seems to be a mistake from deriving the battery level from a working screen, which would show an external battery level during operation.  It is not the plc's battery, as you've checked.

2).  Your last photo directly above this post shows that the laptop IS communicating with the PLC.   The Model etc is shown at the bottom.  I would carefully check all cables for errors, as well as noting next point.......

3).  Are you using a usb to serial adapter?  It must use a genuine Prolific chip.   Other adapters may work, but not completely and correctly.

4).  Did you do the Visilogic installation as Administrator?  Read this:   https://forum.unitronics.com/topic/7917-visilogic-doesnt-work-properly-after-installation-what-install-as-administrator-really-means/

5).  Start your baud rate at 57600 as Dan described, and pay attention the his other comments:

Power up, check communications - COM 1   57,600.

Use Info Mode (At the PLC) to check COM settings.

Does your program modify COM Settings for a device?    Have you changed them?

 

On 9/4/2023 at 5:34 PM, Hasan Haider said:

I am very very disappointed about this PLC.

Please note again that this is forum is manned by volunteers.  It is not the Makers of the PLC responding to your requests. However, from the appearance of all your results it would appear that the PLC is working as best as it can, but has somehow had it's operating system corrupted.  This could be due to large power spikes during your work, or even nearby heavy loads or VFDs.  The issue is likely easily resolved by the forum,  but because we are not on site, it is difficult as we can only go on the information we get.

For now I suggest you follow what Visilogic and the PLC are telling you to do.  Also check what O/S the plc needs by looking at the program you uploaded and selecting Project Information.  This will show you what Visilogic version it was created with.  Note this carefully as this is the version you should be working with on your laptop, and using for all the PLC work.  Later versions of Visilogic than the one used to first create a program can create issues.  This is not a fault, it is the nature of continual improvements.

Link to comment
Share on other sites

On 9/12/2023 at 6:44 PM, Ausman said:

I am very very disappointed about this PLC.

I have been working with Unitronics vision series for the last 3 years, and I agree with that statement (And everything has been working fine on my end, never bought the Unitronics PLCs myself and I want to believe that they are cheap at least) .

However, have you already tried to download the OS again? Have you tried other methods like Unitronics download manager? maybe the problem is the visilogic software? 

and as always it doesn't harm to try different computers and or same computer with different PLC.

 

 

 

 

 

Link to comment
Share on other sites

  • MVP 2023

As Ausman says, if the PLC returns the model number and O/S version then then communication is working properly.

I think what happened here is the OP downloaded the latest version of Visilogic off the Unitronics website (because that's what Unitronics directs you to do) and now it won't communicate because the O/S in the V120 is probably very old.  It's been recommended that the O/S be updated but he hasn't mentioned that he's tried that.  It's not the most obvious thing in the world for a new user.

@Hasan Haider - if you haven't already tried then the way to update the O/S is by clicking on this tab in the communication window -

image.png.12e416ce9c9e14414c1fc7394bc87d1b.png

 

The default baud rate for a V120 is 57600 as DanT says.

Try to update the O/S and then you should be able to go online.  

If this doesn't work, you can reach Official Unitronics Support by emailing support@unitronics.com.

 

Joe T.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

This site uses cookies. By clicking I accept, you agree to their use.