Jump to content

V570 Dead after OS Update

Recommended Posts


I tried updating the OS in my three or four year old V570 and the screen went black and now cannot communicate with it. I have removed the battery and cycled power with finger on the screen, touching it once again, and still cannot communicate with it. I was using Visilogic V8.0.1, and now have updated to 8.6.3, but still have the same problem.

If I cycle the power on the unit it starts beeping until I touch the screen. That is the only sign of life it gives me.

Has anyone had any similar experience.


Link to comment
Share on other sites

If the firmware ever becomes corrupted or you receive a blank beeping screen, the instructions below will fix the problem 99% of the time.

Please put the controller into bootstrap mode and then follow the instructions below for manually reinstalling in “advanced†mode the firmware on the controller.

Be certain to use the max baud rate of 115,200 and physical port 1 of the PLC.

To Enter Bootstrap Mode:

  1. With the power to the PLC turned off, hold your finger down on the touch screen and plug the power in.
  2. With your finger still pressed down count for five seconds, then release and tap the screen twice.

Try individually installing first just the Bin Lib, then just the Boot, then just the O/S all while in bootstrap mode.

In between each step VisiLogic will ask if you want to send a run command, select no each time.


After going through this three step process of Bin, Boot, O/S normal operation should be restored.

Link to comment
Share on other sites

I had the same problem with black screen.

it seems to be the software to update the v570 that has some kind of bug. becouse i used 2hours to get my unit back to life.

i had to change computer 3 times to get the unit back to life. the other 2 computers have same setup and always give me checksum error of some kind.

i think unitronics have to work on a better solutions for firmware upgrade since upgrading this unit is a risky choice.

i allways had problem upgrade firmware and have to try many times before i success without any error.

this unit is 2years old.

so i would like to have an answer from unitronics on this problem.

product is very good but firmware upgrade on this units is a risky bussiness.

Link to comment
Share on other sites

  • 1 year later...
  • External Moderators

I had a V570-57-T40B with this problem.

I follow step by step the download of of Bin, Boot, O/S but the download of the O/S freezes at beginning.

Is the solution to try with an older version of Visilogic?

I have Windows 7 64bits with real serial port (no converter) and Visilogic 9.4.0 with the updated O/S


Link to comment
Share on other sites

  • External Moderators

Hi Reuven,

I have tried with two PCs with build in RS232 115200 baud rate. one laptop with Windows 7 64bit and one old Personal Computer with Windows XP.

I have to try with Unidownloader.

Anyway, this V570 is one of the first V570 with the hide USB and SD card reader. Do you have the perfect combination of bil lib, root and o/s for this unit??

Link to comment
Share on other sites

  • 7 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...