Jump to content

Uniteonics Hardware Issue - SD Card not Present

Recommended Posts

Hello guys,

Ive tried hard to connect all power and other related connectivity parts of the Unitronics V700 but when when I tyrn it on shows SD Card Not Present.  

It was easy to install due to instructions the supplier have been given to me. 

The set up is like this;

The PLC is connected with two Pumps. Each pump has the tags on the Power cabling, Input, Output and Relay Out cables and it very easy to set it up I have just to follow the numbers order and Ive checked more than twice.

Its driven me creazy. Ive had set up before PLC with one pump and everything fine with them. Maybe because this is an installation with two pump and probably am missing something. 

I will try later to bring some picture as evidence and maybe could be more easy to understand this issue. 

I hope that someone here will really help me with this issue.

Link to comment
Share on other sites


Please visit unitronics Helpdesk Portal and search for SD word:


You can find number of articles.

Review next:

What brand of SD cards can UniStream PLCs support? What is the SD maximum size? Does it support SDHC?

UniStream SD cards- Must I format an SD card in order to use it with UniStream?

Prepare Disk on Key (DOK) or SD card to work with PLC

Or format it with SD Memory Card Formatter


Maximum supported SD card size for Vision PLCs is 32 GB, but it is recommended to use SD card with maximum capacity of 16 GB.

*32 GB just show error when prepare it from SD Tools.

SD card should be formatted as FAT32. Other formats are not supported.

Last thing - it is good to make first format as Full, not Quick. this will help to detect SD card defects.

Hope this helps to have active SD card.



  • Upvote 1
Link to comment
Share on other sites

  • MVP 2023

OP mentioned V700, so this is not UniStream. Moved to the correct forum.

Some of what AlexUT mentions also applies to the Vision products, so that response is relevant.

I'd also add that likely the program running on the V700 is trying to write to the SD card. @Bledineeds to make sure there is a properly formatted card in the SD card slot and that the card is 16GB or less. If you believe that you have done this, try a different card and make sure it is formatted with the FAT32 file system and that the proper directory structure has been written to the card. The best way to do this is to download and install the Unitroncs SD Card Suite utility and run the SD Card Formatter. If you go online with the PLC (which you can do whether you have the original program or not), check the values of SB 217 and SB 218. Those operand values can also be checked in INFO Mode.

  • Upvote 1
Link to comment
Share on other sites

First of all, thank you guys for your effort. I appreciate your help.

 I have to check tomorrow with SD card  issue as per your helpful instructions given above. 

Something else that I've noticed  while I was trying to connect the pumps. I tried different pumps, 3 of them and I got the same message from the V700 PLC controller. "Dosing Pump 1 Start Fault". 


As I told you before the instructions to follow for the set-up is very simple. It is enough to follow the number and place them to the correct corresponding numbers. (Cable label 1 place it to the socket  label1 and so on...) I've checked more then twice the power cables but again the same message appears. I've checked also if I am missing or confusing any cable but not, the cables are set in the right way. I cross-checked with another set-up (in this case with a set-up with one pump) and they look the same. 

Probably I am missing something for this set-up, but I don't have a clue where this message is related. I tested with a screw tester the power sockets and cabling and they are fine too. The pumps are on. Maybe I am missing something small which is crucial for the operation.

Any of your answers can be very helpful. 

Thank you a lot , again.


Link to comment
Share on other sites

  • MVP 2023

Others may disagree with my following observations.

I'm not being negative, but this sounds like you have purchased a device that needs partial assembly by the end user.  As such, if there are problems, you really should be talking with the manufacturer/supplier.  This forum is mostly volunteers and there is a fine line here which to my mind is being crossed, in that our time should not be helping to solve some maker's issue.  They  should be offering the needed support.

cheers, Aus

Link to comment
Share on other sites

  • MVP 2023
2 hours ago, Bledi said:

"Dosing Pump 1 Start Fault". 

It is some code in PLC for activate this message. Pump running may be checked via volme of product that is pumped or via signal +24V from pump contactor dry contact  (NO or NC) to input of PLC.

Can you post diagram or system layout for better understand what is wrong.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...