Jump to content

Visilogic 9.3.1 dont recover

Recommended Posts

Hi, I had my visilogic 9.3.1 shutdown wile comunicating with v130 plc. When trying to restart the program I get the usual message "visilogic was not shutdown properly press ok to recover", but when I press ok I get the error " 12subscripts out of range". When I confirm this message it disapears but the program is not starting. When I try to open visilogic again it says that it is already running and can't be opened again. I kill the process in task manager and start visilogic again with the same results as before, "visilogic was not shutdown properly press ok to recover" ......

I've uninstalled the program and reinstalled it, I've tried repair installation but the same thing happens.

Anyone have an idea if there are any other files that have to be deleted in registry or any thoughts on how to fix this?





Link to comment
Share on other sites

There is a   guide in the pinned area of this forum:

         How Do I Perform a Full Re-install of VisiLogic?    

                 this was written some years ago, so    Program Files    can now be    Program Files(x86)                      

some additional notes:     Before  doing the above, check and BE SURE ......

          Program Files or Program Files(x86)


                  Unitronics Visilogic_C      -- MOVE any project files you have there - like in the Applications folder, then Delete the entire folder

                                                                        --  DO NOT Have PROJECT Folders here -  They may get deleted during Uninstalls !!

                 ( Applications folder is not a safe place to keep project files, store your projects elsewhere  -- Visilogic Uninstall can automatically delete this folder)


Save project files frequently  using revision  indexes I the names, so you can go back to a previous revision if necessary.

( In the end , the final project is kept, and the backups can be removed)




  • Like 1
Link to comment
Share on other sites

  • MVP 2023

Hi Sjeggefjes,

I've had this happen ages ago and my virgin storage methods in the post below enabled a rapid fix.  Add "old" to the name of your original folder as extra security....initially don't delete anything.  You may not be at this point now, but it is worth doing for the future and also great for VersionSwapper.  Perhaps you could install Visi onto another similar OS puter and lift the entire Visi_C folder over?  The main point I am aiming for here is for you to try to open the original file once the main program is "back to normal" before doing any uninstall/install at all.  I think it will bring up the same error, but it is worth trying.  Alternatively, you may have burnt it into the 130 and can get it back easily by uploading, which might solve everything fairly quickly?

As a side comment, I routinely save excessively(!) under slightly different names, alternating b/n "project1" and "project2" for the very reason you have encountered.  Or on more complex projects I step up through names from a progressively increased excel file.  This method lets you note your changes in the excel itself, which makes changes tracking a breeze.

Hope it helps.



Link to comment
Share on other sites


Please try as follow:

·         Close VisiLogic (if necessary, close it from Windows Task manager)

·         Turn OFF Windows UAC (User Account Control)

·         Restart your PC

·         Log-in as administrator

·         Run VisiLogic as administrator.

 If it will not help please try as follow:

For Windows 7/8/8.1/10, you need to install the software while the UAC is OFF and after rebooting the PC.

 Please reinstall VisiLogic as follow:

Turn OFF Windows UAC.

1.    Backup you projects and delete all the files related to Unitronics installations.

2.    Erase the “Unitronics VisiLogic_C”  folder  from- C:\Program Files\Unitronics

3.    Erase the “Unitronics”  folder  from- C:\Program Files\Common Files.

4.    Perform Windows update and restart the PC

5.    Log-in as administrator

Save the setup file on your desktop and make sure that the installation file is not blocked (Right click on the file>Properties) If yes, just click on the unblock button:

 Install VisiLogic.

 If software opened properly, Go to the properties of VisiLogic shortcut and under compatibility ticked verify the Privilege Level “Run this program as an administrator”.

i hope it helps..


Link to comment
Share on other sites

  • 3 weeks later...

Hi, I solved this by doing a complete uninstall( uninstall and delete unitronics folder under common files). Reinstalled under new path "c:\program files\unitronics visilogic_c" instead of "c:\program files\unitronics\visilogic_c"  where it was installed before.

This just backup my theory that there where something still in registry that wasn't uninstalled.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...