Jump to content

Recommended Posts

I recently had an EX-RC1 fail on a piece of equipment I have.  I have very little support from the manufacturer, but they thought that just swapping the module would fix the issue. I lost CANbus coms between it and the Vision 1210 hmi/plc.


Well I have CANbus coms back up with the new RC1 module, but the RC1 seems to not be configuring as they thought. It appears it needs a program, or I am having some sort of version conflict.


I do have the program for the 1210 hmi. I do not have anything for the RC1. 


On the RC1, I can communicate with it vi serial only when it is in bootloader mode. Once I move it out of that mode I can't communicate with it via serial or CAN.


Like I said, I have very limited support from the manufacturer of the machine, and of course we need this thing producing.


I have a Vision 1210 hmi/plc, multiple io via modbus, and then this one RC1 via CANbus, and it is connected to 4x IO-D16A3-TO16. Those modules just sit there with the RUN light slow blinking.


I've done a lot of reading and tutorials but nothing is working for me. There is one where you export the i/o from the plc project, but that uses unilogic, and my project is built in visilogic (9.5.0) so it isn't a guide i can follow. Also unilogic doesn't support the Vision 1210 hmi/plc.


As far as I can tell, I need a project for the RC1.  Is there a way to get that from my main 1210 project? Or what am I missing?


Also, when I uploaded the embedded project from the RC1, and did the HWConfig to add the 4 io modules, when I go to download back onto the RC1 it fails due to compiling issues. It does say the RC1 project was created with an older version of visilogic (7.0) but of course that is not available online to download.

Link to comment
Share on other sites

  • MVP 2023

Yes, the EX-RC1 does require it's own program.  It's basically another PLC with limited capability.

Reach out to support@unitronics.com to get older versions of Visilogic.

9 minutes ago, Mvv said:

Also, when I uploaded the embedded project from the RC1,

Does this mean you can still get the program out of the original RC1?

Joe T.

Link to comment
Share on other sites

You need a program the EX-RC1 is a PLC with limited ability.

Send an email to support@unitroincs.com and they will be able to provide the version of the Visilogic required.  Then you can try uploading the EX-RC1 program.  Also double check that the jumpers for the EX-RC1's unit ID are set correctly on the new unit.

Link to comment
Share on other sites

Are there newer firmwares for the RC1 available? There is very little information on these things I can find. I can't get version info out of the old one.


Of course this stuff always happens when the support is on a month long vacation and there's no other support options for a custom machine.

Link to comment
Share on other sites

  • MVP 2023
30 minutes ago, Mvv said:

I do have the program for the 1210 hmi.

Please find example of communication with EX-RC1 in Visilogic Help menu.

......\Unitronics\Unitronics VisiLogic_C....\Examples\Version 900\Project examples\Communications\EX-RC1

You can compare Example V570_CAN Master with your project for 1210  and create project for EX-RC1 from example file.

I think you have INN OUT subroutine in V1210. And it similar to example project. Only input and output setup must be configured


Link to comment
Share on other sites

Or if someone has some ideas to get the program off of the old RC1.


Like I said, I can communicate with all the dipswitches in the up/on position, but nothing else.


I've tried to swap the daughter card from the old RC1 to the new RC1, but that doesn't change anything, whatever is wrong is on that card. 

The old RC1, only the power LED comes on when not in BL mode. CANbus doesn't work, serial doesn't work.

Link to comment
Share on other sites

The board isn't giving me the option to PM a file, perhaps due to my member status?


CANbus is fixed and working, I can communicate with the RC1 through the 1210 hmi and it tests OK with the tester in the "Communication & OS" widget.  One oddity was that the OE had a 120O and a 180O instead of the called out 121's. I replaced the 180 with a 120.


I guess I'll just delete this file later.

MicrosoftTeams-image (8).png


Edited by Mvv
remove project file
Link to comment
Share on other sites

  • MVP 2023
5 minutes ago, Mvv said:

The modules are back online but the main plc isn't getting any of the data from them. Seems to be addressed incorrectly? 

You have two part of communication: Read inputs and send outputs.

This two part must be checked separately. 

Now if no connection in EX-RC1 - outputs is disabled by module program.



1) do you see PLC screen direct (on site)?

2) is it possible to go online Visilogic to PLC and try to see operand?

3) is it possible to connect to your PC via Anydesk?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...