Jump to content

jazz usb-to-serial converter

Recommended Posts


Just checking in what USB to serial converters you would recommend for connecting to Jazz. I have 2 Jazz processors here and I am unable to communicate with either of them. They are older models and only support serial via MJ20-PRG. I am using Unitronics serial cable p/n: MJ10-22-CS25.

I get no errors in Device Manager when I plug in the USB-to-serial converter. It grabs Port 3. But if I set U90 ladder to Port 3, the communication still times out.

I have several USB-to-Serial adapters that I have tried........I have several that are PL2303, but they all show up as "PHASED OUT SINCE 2012, PLEASE CONTACT YOUR SUPPLIER". The one I am using is a FTDI. Could that be making the difference? I believe I have read or heard that Unitronics doesn't like the FTDI even if the driver is installed and the device is working properly. If so, I need to work at getting updated USB-Serial converters.

Please advise.........any good USB-serial converters that you recommend?


Link to comment
Share on other sites


PL2302 phased out?  Hmm...  that's the one I use.

Try this driver for it-


Joe T.

I have tried to update the driver with that link but it acts the same way. Is the PL2302 the one that works best with Unitronics? Does it make sense that it won't communicate across the FTDI?

see attached image of my device manager

Link to comment
Share on other sites

  • MVP 2023

I use china CH340 USB-to-serial converter with all RS232 device - work fine with WIN10.

But probably a lack of communication is not related to the driver or adapter type.

You must read MJ20-PRG manual

http://support.elmark.com.pl/unitronics/PDF/M9091JAZZ/Jazz Add-on Modules/JZ-PRG_INSTL-GUIDE_01-06.pdf

and check voltage on 1 and 6  RS232 power* pin. to GND 2 or 5 pin.

Power from USB-to-serial converter may not be sufficient for the MJ20-PRG adapter to function properly.

Maybe external  +12V power supply needed. Please see app note about this connection. 68Ohm 1W resistor needed.


Link to comment
Share on other sites

  • MVP 2023

You've stumbled into one of the mysteries of the computer world - USB converters not playing well with external microprocessor-based devices.  I Googled "FTDI vs Prolific" and found all kinds of conflicting information, with fanboys on both sides.  Sometimes FTDI works where Prolific doesn't, and vice versa.  And then there is the issue of counterfeit chips, which adds another aspect of intermittent / non-functionality for both manufacturers.

Many moons ago I tried several USB converters and didn't have any luck.  I can't find a definitive answer as to why something as apparently simple as a USB to serial converter may or may not work.  Unitronics offers an official USB converter - part number MJ10-22-CS35 ($37US) which happens to contain a Prolific chip. 

Unitronics has also been integrating a built-in USB converter on all their newer products that has the Silicon Labs chip to try to make it easier on end-users, but even this one has been known to stop talking when Windows 10 decides to update.  Fortunately, Silicon Labs is good about updating the drivers on their website, so if the driver bundled with the Unitronics software doesn't work you can always go there and get the updated one.

I'd say the easiest solution for you is to contact your Unitronics distributor and get the official converter.  Or you can upgrade your Jazz units to the JZ20 series that has the built-in converter.  Or you can do like I do and use Dell Latitude D830s running Windows 7 as your programming computer.  They're readily available on eBay and have a real serial port.

Joe T.

Link to comment
Share on other sites

  • MVP 2023

For what it's worth, I've recently gone to 1903 64 Pro on my main puter and had a devil of a time getting my Shentek 422/485 Isolated converter to work.  All the supposed revamped FTDI drivers that should now work would not play correctly.  In frustration I ended up finding what I had on my "no updating allowed...go away Micro$oft" earlier W10 1803 tablet, as I knew that worked OK.   Found the source file in my records, and on the thoroughly up to date (but now locked down!) system it all loaded fine and works perfectly. It was and I have zipped and attached the whole folder/file for use as needed.

It all seems a bit strange that it works ok when it is supposedly way out of date, but it's a case of "if it ain't broke, don't fix it!"  So I ain't touching it any more!

I guess what I'm really saying is that older drivers are worth trying if hiccouphs persist.

cheers, Aus

CDM v2.08.28 Certified.7z

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...